Jump to content

[Solved] G31M-ES2L with More Than 2GB RAM Causes AirPort/Belkin F5D7001 to Fail


1 post in this topic

Recommended Posts



Problem now solved at:



Which says:


"I found a better way of fixing this problem, apparently the kext doesn't load because it only supports up to 1GB of RAM, so adding "max_valid_dma_addr=1024" to your kernel arguments fixes the problem.



Open Finder and navigate to com.apple.Boot.plist

Add max_valid_dma_addr=1024 to the kernel flags."


So my com.apple.Boot.plist files (inside Extra folder and /Library/Preferences/SystemConfiguration/com.apple.Boot.plist) now includes:


<key>Kernel Flags</key>

<string>arch=i386 max_valid_dma_addr=1024</string>


Many thanks to TheFuzzball for this.



Sorry, just moved this to:



InsanelyMac Forum > OSx86 Project > Hardware Components and Drivers > LAN and Wireless



I've been running the latest Snow Leopard (up to 10.6.7) extremely well on a Gigabyte G31M-ES2L (rev 2) board but I've just started having problems with the Belkin F5D7001 (Broadcom BCM4306) wireless card.


It was all working fine until about 3 weeks ago when I replaced the 2 x 1GB RAM (1 gig in each RAM slot) with one 2GB RAM and an existing 1GB RAM stick. Everything appeared to be ok but then I started getting random disconnections on the Belkin / AirPort wireless card (the bars would grey-out sometimes with an exclamation mark in the middle).


Today I upgraded the RAM again, this time 2 x 2GB 800MHz - both exactly the same matched Crucial RAM sticks. When I booted back into OS X, the AirPort icon was completely blanked out, saying 'No AirPort card installed' even though I hadn't touched the card.


Anyway, I have two of these Belkin cards and tried the other one with the same result. So then I removed one of the RAM sticks and the AirPort connection was back as before. Thinking this might be a BIOS issue I upgraded from FG to FI which is the latest version. The update hasn't made any difference.


I've also tried swapping the RAM around, no difference. So...


One 2GB RAM = Belkin/AirPort works without any problems

Add 1GB RAM = Random card disconnects (not internet connection drops, just wireless drops)


Add 2GB RAM = Blanked out AirPort icon (says no AirPort card installed)


These are fully matched (2 the same) Crucial 800 MHz RAM sticks, stated as 100% compatible on their website.


Any idea why this would be happening? I guess it must be a motherboard compatibility issue (several months ago I tried a small Broadcom card in a PCI adapter and although it worked initially, it started causing problems with sleep and caused shutdowns to reboot instead. Replaced that with a Belkin and it was fine).


Using Snow Leopard Retail, with [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url], E3300, GeForce 8400GS, single WD 500GB HD.



Link to comment
Share on other sites


  • Create New...