Jump to content

VMWare shared folders: programs won't run


moreorless
 Share

1 post in this topic

Recommended Posts

(this post should go in the virtualization forum, but I'm a new user so I can't post there)

 

Scenario: VMWare Player (quite recent version) running on Linux. OSX 10.5.5 installed on it, with zenith drivers and all the stuff mentioned on http://www.chicchedicala.it/en/2010/03/21/...ation-o-player/

 

I was able to get shared folders running on read+write mode.

 

However, I cannot run any program located on shared folders. If I open a terminal (from the OSX virtual machine), I see the programs (bash shell scripts) and they have the execution permission turned on. However, If I try to run any script, I get the typical "unknown option" error you get when trying to run a script without permission.

 

If it matters, I "discovered" this issue while trying to run a "./configure" script for compiling sources located in the shared folder (yes, I installed XCode before trying to do so).

 

Then I found it also happens with OSX executables, and not only with shell scripts: executables won't run if they're on a shared folder.

 

(Yes, I tried to mount vmhgfs with the 'exec' option, but didn't help (no wonder because the docs say 'exec' is a default option)

 

Is there something I can do for fixing this? I really need to compile code located on a shared folder, and it has configure scripts that I must run!!!!

 

Thanks!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...