Jump to content

Hard disk is not detected!


3 posts in this topic

Recommended Posts



After around two months, I've found the core of a very annoying issue on my hackbook pro.





My hard disk (SATA, AHCI enabled) is not recognized when I boot normally, but it IS recognized (most of the time) when I boot in safemode!!


I made a bootable USB stick, with a modified copy of the retail 10.6 DVD.

Now I noticed one interesting difference between safe mode and normal boot: The extension IOAHCIBlockStorage.kext is NOT loaded when my HDD is not detected, and when the HDD is detected, IOAHCIBlockStorage does show up in the loaded extensions list...


The extensions AppleAHCIPort.kext, IOAHCIFamily.kext and IOStorageFamily.kext do load at all times though!



My goal:


Get the IOAHCIBlockStorage kext automatically loaded.


When it does get loaded, I can see (in "ioreg") the IOAHCIBlockStorage is a node between my actual hard disk and the AHCI port (AppleAHCIPort, loads fine after I added my dev id). This confirms my belief that if I can get that kext to load correctly at startup, my problem will be solved.


Searching the whole web, I've only come across one pretty similar issue: http://www.insanelymac.com/forum/index.php?showtopic=187856

I've created a modified DSDT as described in that thread, but to no avail.

I've also tried messing with the kext's plist and AppleAHCIPort's plist to create a depency, to add the device id, etc. but nothing seems to work.

Of course, I've also tried every combination of the custom kexts AppleAHCIPortInjector.kext and IOAHCIBlockStorageInjector.kext that came with Chameleon, but they seem to have no effect at all (by default, I don't use them).



My specs:


AMD Athlon II P320 Dual-Core Processor

Northbridge AMD 785GX rev. 00

Southbridge AMD SB800 rev. 40

SATA Controller:

- Location: bus 0 (0x00), device 17 (0x11), function 0 (0x00)

- Vendor: 0x1002

- Model: 0x4391

Bootloader: Chameleon RC4 with PC_EFI 10.6 boot file

Modified (added id 0x43911002) AppleAHCIPort.kext, added disabler.kext, fakesmc.kext, Apple's PS2 kexts

Other kexts are the original unmodified ones



Thank you very much for any inspiration, help, notice or suggestion!! I'm a bit out of ideas now...

- iPixel

Link to comment
Share on other sites

Here's the SATA node of the ioreg report, when the HDD isn't recognized. I had to type this over so it doesn't include all details. Ask me if you need more details.


+-o AppleAHCI
 +-o PRID@0
 +-o PRT1@1
+-o IOAHCIDevice@0
  +-o IOSerialATAPI
	+-o IOSCSIPeripheralDeviceNub
	  +-o IOSCSIPeripheralDeviceType5
		+-o IODVDServices
		  +-o IODVDBlockStorageDriver
		  +-o SCSITaskUserClientIniter


Normally, PRID@0 should contain a whole path leading to my Hitachi HDD, somewhat like PRD1@1 leads to my DVD.


I really hope someone sees what could be the cause of this issue.

I'm not sure if it's an IRQ conflict, as SATA uses 0x11, if I understand that report correctly, and I didn't find anything else using that IRQ.

Link to comment
Share on other sites

  • 3 weeks later...

  • Create New...