Jump to content

change temporary folder path in Mac OS X


3 posts in this topic

Recommended Posts

I did some research and I am aware that some apps follow the symlink /tmp which, at least in Snow Leopard, leads to private/tmp. For those apps I can simply make a new symlink to the tmp folder I made on another and much bigger volume via Path Finder and drag that symlink to /, overwriting the old one.


Other apps, however, seem to either directly use /private/tmp or /private/var/tmp (hard-coded into their binaries?), or - that's where my question kicks in - hopefully read some BSD Unix value with the whereabouts of the tmp folder.


At this point I could not find any further information. Is there such a value in the BSD Unix sub-system, and if so, how/ where do I change it? Analog to Windows %tmp% and %temp% in the (evilly suspicious) registry?


What I have not tried yet is to even replace both physical tmp folders in private and var with above mentioned custom generated symlink (which points to another volume).




- a 25GB 10.6.6 boot volume, 14GB free

- a ~900GB Apps & Data volume incl. the iPhoto library (totally OK to move off the boot volume accdg. to Apple)


When a ~660MB big CD (onto a 700MB empty disk) shall be burned from within iPhoto (most recent version 9.1.1), burning never starts, but instead we get the following error:

iPhoto: preparing to burn. Insufficient Disk Space: There is not enough free space on the selected volume to perform the library export. It is estimated that you need at least an additional 86GB of space.
Needless to say something within iPhoto is totally miscalculating there.

(as a side-note: a small size CD with 10 images/ 130MB burns without any problem.)


I Googled this exact error without the GB value --> no result at all. Maybe this is a completely new 9.1.1 bug, and it has not officially hit the forums yet because hardly anybody is splitting up into partitions ... ?


Regardless of if Apple ever fixes this calculation bug or not, I want iPhoto to use the tmp folder on the bigger volume, because when a DVD gets burned I do not want the pre-burning temp image to be created on the OS volume. I would already be happy with some tweak utility which can make iPhoto use a different tmp folder.


Any help in this regard would be greatly appreciated. And no, I can already hear some specialist.. at this point I would *not* consider it an acceptable "solution" to increase the OS X sys volume partition size. I have never had a prob with 25GB in years, this is the first time ever I run into a size limit, due to an apparent calculation bug.




Link to comment
Share on other sites

changing the symlink /tmp pointing to another volume keeps OS X from booting into the GUI (gets stuck at blue screen, I guess loginwindow). I looked at /private/tmp and /private/var/tmp but none of their content changed when burning a small CD with just a few pictures with iPhoto, so iPhoto seems to be using a proprietary folder for the temp image. DARN, this sucks!


Since nobody here helped me, I just had to clone the OS volume's content over to the 900GB Apps & Data volume which now has 630GB free space, booted that one, and iPhoto now burns a 700MB CD as it should.


Apple, please, this is ridiculous ... I guess I need to post all of this into the official iPhoto forum over at Apple. I will still keep the 25GB Mac OS partition with 13GB free space and apply the next iPhoto update to it which will hopefully fix this bug.


I am still hoping that somebody has an answer the BSD Unix tmp path tweaking. Thanks.

Link to comment
Share on other sites


  • Create New...