Jump to content

Strange permissions problem


1 post in this topic

Recommended Posts

Guys, I have this problem with permissions. I am running 10.5.8 now and have been running leopard for 2 years. Tiger ran on this same machine for several years, flawlessly, although I had to do a lot of patching. It's an Asus board with 915 chips. 3 ghz processor and 4gb ram. It took a lot of tries to get the right selections at installation but it worked, except for mic audio which was no issue as I use a sound blaster usb. No patches. I saw the spinning wheel a little more than I should but never had any real problems. This machine ran much slower on Leopard than on Tiger. Big difference. I had to install Leopard to be able to run some apps I use daily.


Here's the problem. Whenever I move files from one drive to another I then have to use password on that file from now on. Any file or folder I move to the desktop suddenly needs a password to move it again.


After get info on the folder or file, in the permissions section there is first "everyone" with read only perms. Then "admin" set at read and write. MY user account is an admin. Then another "everyone" that says no access. I can not remove any users but can add myself and read and write and all is well.


Next, when I use Diskutils I get what looks like pages of errors on verify permissions and set it to repair. It does not repair. I used pfix and xmod and they will not repair permissions as well. I ran the install disk and tried repair permissions from there. Found the errors but did not fix them.


I have not used terminal since the biginning of osx86 testing. Used it a lot then. If there is way to help with this problem from terminal - I am all for it.


Anyone got any ideas?

Link to comment
Share on other sites


  • Create New...