Jump to content

Snow Leopard on eMachines T5274


codeThatThinks
 Share

5 posts in this topic

Recommended Posts

Hi,

 

I have an eMachine T5274 desktop with the following specs:

 

Processor: Intel Pentium E2180 Dual-Core @ 2.0GHz

 

Graphics: Intel GMA 950 (Desktop Version) w/ 2772 as Device ID

 

Motherboard: ECS 945GCT-M3

 

Networking: Realtek RTL8100C

 

Audio: Realtek ALC883 7.1 Channel High Definition Audio codec

 

Display: 1440 x 900, 32-bit colors, 75 Hz refresh rate

 

I've installed Kalyway Leopard 10.5.2 on one partition and it works almost perfectly.

After weeks of fiddling, I've been able to install Snow Leopard 10.6.0 on another partition and got it to boot using the 64-bit kernel. Now I have three major problems to fix:

 

- Get graphics to work with the Intel GMA 950 (I'm stuck at 1024x786 @ 60 Hz)

 

- Get PS/2 mouse and keyboard to work (currently using borrowed USB mouse and Apple Wireless Keyboard)

 

- Get networking to work (had to disable some Realtek kext to get Snow Leopard to boot)

 

The Leopard partition is only there now to help with getting Snow Leopard to work, and it will be replaced with a Windows XP partition later.

 

Would anyone be kind enough to help me with this?

Link to comment
Share on other sites

Okay. I've been able to solve the networking problem. I found a patched version of AppleRTL8139Ethernet.kext and replaced it in the plugins directory of IONetworkingFamily.kext which is in /System/Library/Extensions. Repaired permissions with Kext Utility and bam! Networking was up and running even before I restarted! That's why I'm typing this ON my snow leopard installation.

 

I added AppleAPCIPS2Nub.kext and VoodooPS2Controller.kext to S/L/E also, and now have keyboard working. PS/2 Mouse still doesn't work though :)

Link to comment
Share on other sites

Updated to 10.6.5, had to use IONetworkingFamily.kext from Kalyway 10.5.2.

 

Updated again, this time to 10.6.6 (i've now got Mac App Store!) and had to use patched IONetworkingFamily.kext from 10.6.0.

 

Okay, so whole the whole networking problem is fixed (you can easily PM me 24/7 to find out details on this), so I've now began to takle the graphics problem.

 

I have no resolutions to pick from, no QE, no rotation. System Profiler generically names it 'GPU', but does give me the ID number, 2772, and the revision number, 0002. I've tried some kexts, but all of them refuse to load. EFI strings do nothing. I've narrowed down the remaining options, and decided DSDT patching is the only real solution.

 

I'd love 1440x900 running on 64-bit kernel in 10.6.6, but so far I've only found ways that don't work. Please, please help me!

 

@Dr. Hurt and the rest of experienced DSDT patchers:

I've tried your DSDT patching guide for the Intel GMA 950, and tried to patch the kext myself, but always get some kernel panic with IOACPIPlatform and IOPCIFamily. Is it some address error? My board is the exact same as the users eject and OSXtoZ, although my DSDT looks completely different (I have a _SI section). I've been able to successfully self-patch the DSDT to fix CMOS-reset, but I still consider myself below noob when it comes to DSDT patching.

 

Sorry I wasn't able to post at the end of your thread, I'm only able to post in the New Users Lounge right now.

Link to comment
Share on other sites

  • 5 months later...
  • 1 month later...
I've installed iatkos s3 v2 snow leopard and from the beginning i have usb network working and also sounds ok.

I only have display resolution problem with intel 945g 2772 id.

Is there any solution?

 

Sorry for my long response time, I've had other things to do.

 

Yes, there IS a solution. It's called DSDT patching. I recommend trying out this first: Final solution (FIX) for GMA950. If you experience problems with that, you'll have to figure out a patch that is specific to your system. I'll try to post my fix soon.

 

After you made sure that it works (i.e checked System Profiler), you can use the standard Apple kexts to get full support. I've attached them to this post.

 

Good luck,

Ian

AppleIntelGMA950.zip

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...