Jump to content

Acer Aspire 5720z - Mac OS X 10.4.8 [JaS AMD-Intel-SSE2-SSE3 with PPF1]


jihaa
 Share

4 posts in this topic

Recommended Posts

Hi everyone,

 

I have tried several hackintosh distros before, including: Kalyway, iAtkos, iDeneb, iPC and so on. Up from 10.5 (meaning Leopard or Snow), there was no distro proven to be working on my hardware (sadly).

 

Let's start with the hardware, this supposed to be a guide after all:

 

- CPU: Pentium Dual-Core T2300 @ 1.73 Ghz

- RAM: 3GB DDR2 (1+2GB)

- HDD: 160 GB (two partitions by standard 80+80)

- GPU: Intel GMA x3100

- No bluetooth

- Firewire, Express card and SD card reader, IR port, 4 x 2.0 USB ports

- OS: Windows 7 Ultimate 32bit and Jolicloud Linux 1.X

 

The plan is as follows:

 

1. Downloading the JaS 10.4.8 PPF1 distro and burning it with PowerISO (it works for boot very good)

2. Partitioning HDD to: 80 for C: + 40 for D: (shrinking) + 40 for Mac Partition

3. Installing Mac OS X 10.4.8 on partition 3

4/a If not working out of the box, experimenting with drivers and update the changes here

4/b If working out of the box, writing a step by step guide for this setup

 

"Acquiring" the distro is at 30% currently. I will get back to this tomorrow by installation and keep you guys posted. Hope this helps somebody with the same setup...

 

If you have questions about the unsuccessful attempts of 10.5 and 10.6 installations, please ask only by indicating, that it is OFF TOPIC!

Link to comment
Share on other sites

Phase 2 report and update:

 

Okay, so here is where I am now. JaS 10.4.8 distro proved to be working after all!!! At installation I went with the following setup:

 

- Intel kexts

 

everything else unchecked.

 

Step by step:

1. Boot up the install DVD

2. Select Disk Utility

3. Select the free partition you will use for Mac OS X (I made a 15GB)

4. Format it firstly as MS-DOS (Erase)

5. Format it secondly as Mac OS X - Journaled

6. Close utility

7. Select what I mentioned above

8. Skip disk check

9. Wait for install to complete and wait for restart

10. Boots up fine, complete new account information fields

11. !!YOU HAVE A WORKING OS X ON THIS MACHINE!!

 

Negative side effects:

Only firewire and USB works out of the box. Screen resolution is 1024x786 and you can't change it (but there are alternative ways of chaning it), WiFi Adapter (Atheros) is not working either, Ethernet adapter is not recognized, Sound is not working (not recognized)... Keyboard also acts funny (some keys are falsely placed).

 

Positive results:

Speed is AWESOME! You can get to desktop at 9-10 seconds! Apps and tools open lightning fast and visuals are also fast! Only screensaver seemed to lag a bit. Exposé, Dashboard works fine.

 

**

 

Okay, but here comes the sad part: Windows will die on you. No, don't be affraid of course it can be repaired, but then you will get a "HFS+ Partition" error if you try to boot in OS X...

 

So here is what I'm trying out now: http://www.youtube.com/watch?v=5uavcyF0BMA...ayer_detailpage

 

This guide claims to solve the error, and I will report if it works on 10.4 as well or not.

 

**

 

Solutions what I tried so far:

 

- Chain0 fix didn't work (depending on boot.ini, which is Windows XP and not 7)

- EasyBCD edit can't fix this - probably it's for 10.5+ (it has an EFI and MBR boot option but neither works)

- bootrec and bcdedit from install disk or Windows only worsens the situation - they will destroy the OS X bootrecord completely

 

Possible cure:

 

1. Booting up the JaS install disk and using terminal for writing a new boot record for OS X partition

2. Restarting and booting up 7 install disc, making the Windows partition active

3. Restarting and booting the 7 disc to auto-repair Windows

4. Restarting and booting the 7 disc to make the OS X partition the active

5. If it really does not work without the profile fix mentioned in the guide, applying that as well

 

I will report back soon to tell you the results.

Link to comment
Share on other sites

Holy s**t, that DID work! OMG, I'm surprised as hell!

 

Okay, so now let it be officially confirmed: Mac OS X 10.4.8. JaS PPF1 distro works on Acer Aspire 5720z!

 

So, please follow the first part of the guide if you want to do it as well, then proceed with the tutorial video from youtube after you installed it succesfully. You can leave out the profile recreation part as well, it works for me without doing it.

 

If you have questions regarding this problem, feel free to post them here!

 

 

peace.

Link to comment
Share on other sites

Hi, minor updates comin' up.

 

The resolution turned out to be a dead end. There is no X3100 driver for 10.4 as far as i read, and without that, res. can't be changed to the native 1280x800...

 

Also, still no luck with the sound and networking.

 

BTW, USBs are working fine, incl. mouse and pendrives. The system also reads the NTFS of Windows, so alternatively you can use those drives as "shares" (you download stuff with windows then boot in os x and use it).

 

I found a style overhaul for Tiger to make it look like Leopard, it's called "Liger", and it's fully functional - so at least you can make it look like 10.5... kind of a fail though...

 

Nothing else...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...