Jump to content

Install IATKOS s3 v2 10.6.3 ON HP 530 :)


bahha
 Share

11 posts in this topic

Recommended Posts

Hi everybody smile.gif:D

 

This my first post here after registering :

Today I succeed installing Iatkos on my laptop HP530 model

 

And I'd like to share my hard experience with it. to make some owners of the same laptop relief

 

my laptop

specs:

 

Specification HP 530

Processor Intel Core 2 Duo T5200 at 1,6 GHz

Chipset Intel 945GME

Memory 1 GB DDR2

HDD [GB]

160

Optical device

DVD+-RW

Graphics adapter

Intel GMA 950

Screen [inch]

15,4 (1280x800)

Connectors 2xUSB, VGA, PCMCIA, Wireless 802.11b/g

------------------------------

so after installing and reinstalling erasing the disk many times

 

now I have triple boot on the same HDD :^) XP + Ubuntu 10.10 + Iaktos s3 v2 10.6.3

 

anyway for the snow leopard to work it's simple follow the steps bellow :

  • you have to make sure of the MD5 of the iso image you downloaded for me I used a soft in ubuntu 10.10 ( furious iso or something like that) when the MD5 matches the one that come with the iso image of IAktos proceed to burn ( burn with the lowest speed to make sure it's fine) I even made a cheksum after burning the DVD I created an iso image from the DVD and checked it again.

  1. start the laptop and press F10 to enter Bios setting go to device configurations:
  2. Disable USB Legacy Support ( I tried to enable it and it gives Panics so don't enable it after the installation.

  • Disable SATA

  • Disable Dual core ( after the installation you can switch it back to enable if you want to )

  • press F10 to save the setting. exit from Bios by accepting changes you made.

3. insert the DVD restart if it doesn't boot from DVD press F9 just after the HP logo appears.

and choose to boot from Optic drive .

 

4- when the DVD boots press F8

 

5- type : -v busratio=10 ( the text command will appear down left pay attention because the keyboard changes to Qwerty so q is a ) press enter

 

wait for the pc to boot after a while the last line will show ''system shutdown failed'' don't do anything just be patient ( I had my Iphone to play games while waiting :(

 

just wait about 6 min because of many reinstalling I used my watch to measure installation time

 

when it boots with the white screen and apple logo wait again then choose your language installation then open disk utilities and erase the hard disk partition that will hold the osx.

when done close the disk utilities.

 

6- customise:

 

bootloader = Chameleon v2 RC4

 

bootlaoder option = 32 bit boot

 

modified Kernels = qoopz 10.3.0 or the other qoopz

 

Sound = Voodoo HDA (only)

PS/2 = Apple Ps/2 (only)

Patches= all

EVO reboot

 

that's all I did no more no less

 

The usb fix; Ethernet ... can be downloaded from the forum here that where I got them too.

 

7- Install : It'll calculate timing (18 min) and freeze about 7 min then goes to (11 min) and again

(18min) just wait the whole installation from the customization to the end take about (28 min)

 

8- Congratulation

 

9- now look for the rest of the drivers in the forum

 

IMPORTANT : install OSX86 Tools and make a buck up of kernel and extensions .

Use Kexthelper to install Drivers (google Kexthelper)

if anything goes wrong (Kernel panic) restart with -X and lunch Osx86 tools and restore

 

That's All Special thanks to OSX86 community

 

This may work for other HP s

 

for triple boot PM me

 

I hope this will help somebodytongue.gif

Link to comment
Share on other sites

  • 2 weeks later...
can u tell all the driver that u've selected ? c

 

yes eveything on C if you have any problem with that just ask

 

yes I have everything on C I have two partitions Mac and NTFS for windows and ubuntu

 

yes I have everything on C I have two partitions Mac and NTFS for windows and ubuntu

Link to comment
Share on other sites

Well, bahha is right about the installation but you still need to search for the drivers ( in forum or google it).

I've been installed many times iatkos s3 v2 to have it right now on my hp530.

What will not work:

- ApplePS2 ( keyboard will work , but you will not have mouse). You must add a USB mouse to your computer to work with him. To resolve mouse problems just copy the ApplePS2Trackpad.kext in /Extra directory, clean extensions permisions and cache and the mouse will work but not like a real touch pad ( I can't click using my finger on it ).

- After the update to 10.6.6, USB will not work anymore, so you have to install again USB Drivers due to some important changes made. Follow this http://blog.nawcom.com/?p=347 to have USB working.

- Well everything will work, after the update you can enable the Dual Core Processor again but will not became stable ( after enabling this option from Bios I was having some kernel panics , so it's good idea to remain deactivated).

- ACPI Cpu -> well I've been noticed that the OS X cool my fan processor very hard. I mean the fan cooler from the CPU will be at maximum .. so it's not a good idea to do that .. I think this must be fixed , in Windows the Cpu Fan is was at low ..

 

That's all for the moment.

 

 

Cheers mate,

Seelview

Link to comment
Share on other sites

  • 2 months later...

Installed OS X using your guide. But Kernel panic from ElliotforcelegacyRTC.kext...

Then i tried to remove the kext by popping in the installation DVD, & using terminal. But i can't get rid of this kext. Since installation it couldn't reach the desktop for a single time..I have run out of idea to make that thing work..

i need help...seriously ;)

post-610000-1304173421_thumb.jpg

post-610000-1304173492_thumb.jpg

Link to comment
Share on other sites

Installed OS X using your guide. But Kernel panic from ElliotforcelegacyRTC.kext...

Then i tried to remove the kext by popping in the installation DVD, & using terminal. But i can't get rid of this kext. Since installation it couldn't reach the desktop for a single time..I have run out of idea to make that thing work..

i need help...seriously ;)

 

Hi

 

first is your laptop HP530

I'm confused are those picture taken before or after the installation ?

Link to comment
Share on other sites

Hi,

I tried to follow steps from the first post but I encountered a problem. When it comes to choosing language my usb mouse doesn't work. I can go one step further with a keyboard only, but next window (partition selection) is not passable for me as I don't know how to access the top menu with the keyboard. So, could anyone help me with the usb mouse issue or at least tell how to access top menu with keyboard alone? My mouse works well with HP530 under Ubuntu Live, so I guess this is not a pure hardware problem.

Link to comment
Share on other sites

  • 2 weeks later...
Hi,

I tried to follow steps from the first post but I encountered a problem. When it comes to choosing language my usb mouse doesn't work. I can go one step further with a keyboard only, but next window (partition selection) is not passable for me as I don't know how to access the top menu with the keyboard. So, could anyone help me with the usb mouse issue or at least tell how to access top menu with keyboard alone? My mouse works well with HP530 under Ubuntu Live, so I guess this is not a pure hardware problem.

 

 

HI

I think your laptop touch pad will work instead of a usb mouse weird issue though 

Link to comment
Share on other sites

  • 2 weeks later...

Hi I just followed the instructions and got 10.6.3 on my HP530 but I guess being new at this and without experience... I noticed that aside from the drivers for Graphics I can't find anything working.... and worse is the USB ports don't work... did I do anything wrong? can someone guide me to the right direction here?

 

Any help would be appreciated

Link to comment
Share on other sites

  • 2 weeks later...
  • 1 month later...
Installed OS X using your guide. But Kernel panic from ElliotforcelegacyRTC.kext...

Then i tried to remove the kext by popping in the installation DVD, & using terminal. But i can't get rid of this kext. Since installation it couldn't reach the desktop for a single time..I have run out of idea to make that thing work..

i need help...seriously :)

 

I've used the same method and I've deleted this kext. But I was using terminal from installation GUI (Utilites->Terminal), because I didn't want to play around with mounting of partitions. Maybe this hint will help you. :(

 

p.s. remember to clear cache or force system to rebuild it with -f parameter

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...