Jump to content

Chameleon says efi_inject_get_devprop_string and won't boot


1 post in this topic

Recommended Posts

Hello there,


I've got a Toshiba A200-1AG laptop (core2duo) and I just discovered the iAtkos S3 v2 yesterday, so I decided to give it a try and get rid of my unstable OSX86 (10.6.6 - EmpireEFI).


It installs just fine, I made a partition for SnowLeo at the end of my HD, following my 2 NTFS partitions for Win7. I select the default packages, chameleon bootloader, plus some extra drivers for my hardware (audio,lan,ps/2, and some laptop options).


The problem is, when I finish the setup, i get a perfect dual boot with windows, but when I select to boot chameleon it shows up correctly, but when loading the Snow partition, it panics and restarts just after saying efi_inject_get_devprop_string NULL trying stringdata.


I guess that error is not the problem, because I can actually boot my OSX from the iAtkos S3 DVD (using just its bootloader to boot my partition), it shows the same error again but with no restart, and EVERYTHING works fine, I never had such a success with an OSX86 installation regarding hardware functionality. Everithing works (audio, lan, wlan, dvd-rw, battery status, bluetooth, firewire, accelerated graphics).


The only problem is that it only boots from the DVD bootloader, and I tried almost every possible flag with my HD chameleon (busratio=16,cpu=1,cpus=1, the memory thing max 4096, and many more) it just keeps giving me the same error and reboot.


Should I recreate the bootloader files and structure from the DVD in my HD, so it does the exact same process? can you think of a different way to get this solved?

Link to comment
Share on other sites


  • Create New...