Jump to content

Help getting gtx260m working on Asus g72gx laptop


brutusx00
 Share

4 posts in this topic

Recommended Posts

Have been running OSX 10.6.6 on my asus g72gx for a couple weeks thanks to jokawilds guide here

 

http://www.insanelymac.com/forum/index.php...15709&st=80

 

Wifi, audio, battery all working well enough for me.

 

The problem is I have a lot of graphic tearing, can't run imovie, and QE/CI is not working. Also, VLC just shows a black screen (but audio works) when I try to play a divx avi file. Quicktime will work ok, but the video is choppy.

 

I have nvinject 0.2.2, and it shows up in system profiler.

 

Any suggestions? I would love to be able to run my steam games, but not even app store games will run.

 

I only have two weeks of experience with OSX, so I am well into noob territory.

 

*EDIT* Before anyone says it, I have read every thread here concerning "g72gx", and "gtx260m" and haven't found any solutions. A few claim they have it working, but don't tell how.

Link to comment
Share on other sites

I have finally fixed the GPU problem. Translucent menu bar, frontrow, imovie, preview and vlc now work without tearing. Basic hardware acceleration and QE/CI have been enabled. I have been working on this for days. I haven't used a mac before, so this may be simple stuff to everyone else. I couldn't find any answers in the forums so I thought I'd give my two cents.

 

Install hazards distro following jokawild's guide here:

http://www.insanelymac.com/forum/index.php...15709&st=80

 

Wireless will not work yet, so plug in.

 

!!Delete disabler.kext, sleepenabler.kext, and applehda.kext before you update!!

 

after update delete airport utility app from apps folder. Reboot and wireless should work.

 

now find voodoo battery.kext to enable the battery charging icon.

 

Download chameleon 2 rc4. Drag the file "boot" from the chameleon folder into the root harddrive. There should already be a "boot" file there, just overwrite it. Upon reboot you should have gpu acceleration.

 

If you still don't have acceleration enabled you'll want to try installing the following kexts:

geforce

nvdanv50hal

nvdaresman

nvenabler

nvenabler 64

nvinject

nvkush

 

If you don't get gpu acceleration working after that you will need to modify the info.plist files of these .kexts as mroy explains in this forum post:

http://forums.macrumors.com/showthread.php...745&page=10

 

The proper string for the GTX260m should be 0x061810de.

 

There were a few other .pkg's I installed along the way, but they were most likely not the answer.

If all else fails, also try googleing the following files.

 

Enabler_for_Nvidia_and_multiple_ATI_cards

g92_10.6.4

XDarwin Nvidia Installer V 1.1 OSX

Link to comment
Share on other sites

The trackpad is still giving me trouble. It worked as a simple trackpad after install. Not even tap to click worked, had to use the buttons. Haven't been able to get any sort of multitouch to work yet, but I was able to get tap to click, and scrolling to work. Heres how.

 

install voodoops2controller.kext Not sure if this had anything to do with getting functionality.

 

copy appleps2controller.kext to desktop. edit info.plist and remove "Apple"

 

Info.plist is located in /System/Library/Extensions/ApplePS2Controller.kext/Contents/PlugIns/ApplePS2Trackpad.kext/Contents/

edit this part of the file

 

<key>Synaptics TouchPad</key>

<dict>

<key>CFBundleIdentifier</key>

<string>com.apple.driver.ApplePS2Trackpad</string>

<key>IOClass</key>

<string>ApplePS2SynapticsTouchPad</string></font>

<key>IOProbeScore</key>

<integer>5000</integer>

<key>IOProviderClass</key>

<string>ApplePS2MouseDevice</string></font>

</dict>

 

reinstall the .kext and reboot.

 

if that doesnt work, copy it to the desktop, and then delete it from the extensions folder. You will need to plug in a usb mouse and keyboard to copy it back to your extensions folder.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...