Jump to content

DELL Inspiron 530 / Vostro 200 (no AHCI option available!)


BerggreenDK
 Share

3 posts in this topic

Recommended Posts

Hi there.

 

I have two very similar DELL Vostro 200 PC's.

 

They both have:

CPU: Intel Core2 Duo 3.0 Ghz

RAM: 3 GB and 4 GB

 

LAN/Audio: The motherboard of this machine is Foxconn G33M02 so the onboard LAN and AUDIO is Realtek.

 

Graphics: I dont use the onboard graphics, as I want good 3D support and uses nVidia 8600 GT 512mb and nVidia 8800 GTS 640 mb

 

First problem for owners of this model:

 

We dont have AHCI setting in the BIOS. No way to force it as I know.

I tried [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], Boot 132 and many others. Didnt work. Until I discovered a very nice DELL Inspiron 530 ISO boot loader thing. (Attached here)

 

After burning this to CD and boot, I was able to get the normal "chameleon boot loader", swap my original 10.6.3 DVD into and hit F5... bingo... I could now boot the installer as supposed to.

 

The installer completes and you have 10.6.3 running without any hardware support. But its installed without AHCI

 

Next problem for me was to get the LAN and graphics to work as a minimum.

 

As the hackintosh newbie I was, I didnt write down my 50 different approaches as I tried one thing, downloaded another, to USB stick, move stick, try again. Nope, didnt work. new thing downloaded, to USB, switch back and forth. Reboot hackintosh... etc.

 

Finally I got ONE Vostro 200 up and running with 3 GB RAM, 120 GB harddrive and 8800 GTS... cool! the sound and network is running too and 3D is accelerated as I needed for my developing and testing of 3D games.

 

......

 

So, dear fellow "no AHCI" users (DELL Inspiron 530 and Vostro 200 in special) - it IS possible to get it running. Just burn the attached ISO to a CD and boot from that instead of all the other popular bootloaders.

 

Some final thoughts:

1) I've tried to "redo" this install on my second machine. But so far without luck.

2) I have to boot it from the DELL iso thing everytime. Not a problem for me, but I believe the bootloader should be possible to move to a partition too.

 

Therefore I have added the BOOT ISO on this message and I hope some more experienced hackintosh wizards in here will have a look at it and tell me what to do or perhaps tell me what kexts/installers I need to apply to get the same LAN, AUDIO and GRAPHICS to work everytime with this so newbies like me can just boot this baby and off we go.. its running.

 

 

That would be perfect. But is it possible in here?

i530_Boot_CD.zip

Link to comment
Share on other sites

  • 4 weeks later...

Thanks for posting the Inspiron 530 bootcd, it worked for me + retail 10.6. I just got one of these systems 2 days ago and thought I would try to get this working. No AHCI option really stinks. I was able to get the onboard network (Intel) and video (an NVidia card) working with [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], but no sound no matter what I did (Realtek ALC888). Booting off disc every time is very annoying too, plus the 10.6.6 combo update turns it into a non-bootable system, so this really seems like an uphill battle to me.

Link to comment
Share on other sites

  • 4 months later...

in DSDT inject ESB2 to sata (SAT0) and fix usb device-id's then switch the IDE mode in bios to RAID and it works!

tested with chameleon2 RC5 rev 1017 with 8400GS GraphicsEnabler=Yes

smbios.plist of macpro3,1

GeneratePStates=Yes GenerateCStates=Yes

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...