Jump to content

HOW TO: OSX86 10.6.6 On Lenovo Thinkpad SL300 (In progress)


midevilshadow
 Share

1 post in this topic

Recommended Posts

After spending days on getting my system to run SL, I decided I'd not put my time to waste so here's how I did my install.

 

NOTE. This worked for me; it does not mean it will work for you. I'm not responsible for any damages that occur to your laptop. If you're unsure of something, do some research.

 

LAPTOP SPECS

Lenovo ThinkPad SL300

 

CPU - Intel Core 2 Duo T5870 2.0GHz

GPU - nVidia Geforce 9300M GS 128MB

Audio - Intel 82801I (Show up as Conexant High Definition SmartAudio 221 in Windows)

LAN - RTL8111/8168B

WLAN - Atheros AR5BHB63 (Shows up as ThinkPad 11b/g Wireless LAN Mini PCI Express Adapter III in Windows)

 

Note about the WLAN, I confirmed the model number by taking apart the laptop and looking at the PCI card itself.

 

WHAT DOESN'T WORK YET

WLAN - Can't find support. Tried rebranding without success. Planning on buying a better card n eBay

SD Reader - Still looking for support

Hot Keys - Brightness works right away but the rest of the Lenovo hot keys don't

Sleep

 

PRE-INSTALLATION

1) Download Snow Leopard 10.6.1-10.6.2 Intel AMD made by Hazard

- Burn to a DVD

 

2) Before you install OSX86, you might want to remove the whitelist of WLAN cards that Lenovo placed on the bios. Otherwise, the laptop will refuse to boot when a non whitelisted WLAN card is detected. If you're planning on using a Lenovo approved WLAN card, then this step is not necessary.

Otherwise.

------

Go here: http://tommy.net.cn/2010/11/23/lenovo-notebook-whitelist/

and download the SLIC 2.1 for SL300 (credit to tommy)

This bios version is 29. As of today, the up to date bios from Lenovo is 30.

------

Go to Lenovo's support site and select the bios utility for SL300 (their website is a bit wonky sometimes. Make sure you've selected SL300.

http://www-307.ibm.com/pc/support/site.wss...ocid=MIGR-70039

Scroll down to the bottom and download the BIOS Utility version 28

"Install" the downloaded file, but DON'T "install" the other part after. In other words, do not flash the bios just yet.

Go to C:/Drivers/Flash/6auj17us/

Find and run winflash

Select the downloaded edited bios from tommy's site. And flash.

---If winflash complains about the bios being older than your current one, close winflash

------reinstall the bios utility install program from lenovo. This time go all the way through and flash v28

---------this will downgrade your bios to one older than v29

------------after computer reboots, try running winflash with tommy's bios again. It should work this time.

 

3) Restart computer and go into bios.

- Set SATA to ahci

- Under config-cpu, change "Use multi-cores" to disabled. Otherwise the boot disk won't load (don't worry, you can re-enable the second core after installing).

- Save settings

 

4) Place leohazard disk. Reboot laptop and keep tapping F12 until a boot menu appears. Select the dvd drive.

 

5) Run the disk without any options.

- Find disk utility on taskbar and erase the harddrive to a mac file format. Go to partition and make sure the GUID boot is chosen. If not, repartition and choose GUID.

 

6) Close disk utility and continue with installation until it says "Customize" and "Install". Choose customize

 

7) Choose:

- Mac OS X 10.6.2 Update Combo

BOOTLOADER

- Chameleon RC3 PCEFI 10.5

GRAPHIC

- Graphic Enabler

AUDIO

- AppleAzaliaAudio

LAPTOP

- AppleACPIBatteryManager

- FunctionFlip - Bightness control

- VoodooBattery

- VoodooMonitor

- VoodooPower

- VoodooPowerMini

- VoodooPS2Trackpad

SYSTEM

- AppleRTC

- SMBIOSResolver

- UUID

OTHER

- Rosetta

 

(Many of these probably aren't needed... but these are what I chose).

I can guarantee however that you should chose AND ONLY chose GraphicsEnabler. Choosing other graphics options will mess up your install.

Also, LAN and Kernal selections are not necessary because they work OOB.

 

POST INSTALLATION

- Make sure screen resolution is correct.

- Check for QE: press F12 and add a new widget. Does the new widget cause a water ripple? Yes? Good. If not, then sorry but QE is not working and I don't know how to help you. I spent days until I found a working solution for me.

-----

- Go to System/Library/Extensions and delete sleepenabler.kext (so that you can update to 10.6.6)

- Go to applications and run kext utility. Allow it to do it's thing and don't worry if it says extensions.mkext not found.

-----

- Reboot computer, and go into the bios. Re-enable the second core of your cpu. Make sure to save

- Start OSX86 again, and run software update. Update to 10.6.6

-----

- After rebooting again, congratulations. You're currently stuck at the same step I am.

- Everything should be working except sleep, sd cardreader, most hotkeys, and wireless. If I progress further, I will update. If you've followed my guide and have found any solutions to my plight, feel free to let me know.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...