Jump to content

VoodooMonitor no Snow 10.6.5


Alex Novelli
 Share

17 posts in this topic

Recommended Posts

Abri o VoodooMonitor pra verificar se estava tudo ok depois de algumas atualizações do Snow e pra minha surpresa no 10.6.5 ele está com a frequência das CPUs (Quad Core) no máximo, travadas...

Abri o Photoshop e observei que não existe nenhuma ocilação, o que antes acontecia.

Alguém sabe me dizer qual é o problema?

 

Utilizo DSDT e minhas kexts Extras são:

- AD1988bFix

- fakesmc

- LegacyAppleYukon2

- OSXRestart

e, obviamente: VoodooMonitor

 

Obrigado.

Link to comment
Share on other sites

Também tive este problema após atualizar para 10.6.5, o CSTInfo ficou vazio mesmo inserindo o _CST manualmente ou usando o GenerateCStates, consequentemente o gerenciamento de energia deixou de funcionar e a temperatura do CPU aumentou bastante. Verifique com o comando

ioreg -lw0 | grep CSTInfo

Fiz uma instalação limpa, atualizei e tudo funcionou normalmente, então reinstalei o combo sobre a partição com problema e voltou a funcionar.

Link to comment
Share on other sites

Também tive este problema após atualizar para 10.6.5, o CSTInfo ficou vazio mesmo inserindo o _CST manualmente ou usando o GenerateCStates, consequentemente o gerenciamento de energia deixou de funcionar e a temperatura do CPU aumentou bastante. Verifique com o comando

ioreg -lw0 | grep CSTInfo

Fiz uma instalação limpa, atualizei e tudo funcionou normalmente, então reinstalei o combo sobre a partição com problema e voltou a funcionar.

 

O resultado foi: "CSTInfo" = 19136773

O que significa?

 

Acabei de fazer uma instalação zerada e atualizei. Anteontem mesmo.

Link to comment
Share on other sites

Estranho, então deveria estar funcionando.

 

Roda esse comando

ioreg -lw0 | grep PerformanceStateArray

 

Você está usando o DSDT com _CST ou o generate states do Chameleon RC5?

 

Resultado: "PerformanceStateArray" = (<0e0b0000c05701000a0000000a0000002248000022480000>)

 

Eu não sei configurar DSDT, quem configurou pra mim foi vc old. Não estou usando o Chameleon RC5, e sim o RC4.

O DSDT está anexo.

dsdt.aml.zip

 

Por falar no assunto, o Chameleon RC5 trás vantagens para nosso chipset?

Obrigado.

Link to comment
Share on other sites

Estranho, só tem 1 P-state, deveria ter 2.

 

Faz um boot sem DSDT e usa o Auto-Patcher da P5E

http://www.insanelymac.com/forum/index.php?showtopic=237007

 

Ative as opções generate C e P states do RC5. Ele também corrige o restart, pode remover a kext.

 

Só uma dúvida, eu instalei o Chameleon RC4 em uma partição (a do Leopard) e depois tentei reinstalar ele em outra (do Snow) e não consigo cara... tem algum macete? Por mais que eu aponte a partição do Snow na instalação ele não puxa as configurações dela... continua usando do Leopard.

Eu uso sempre seu tutorial via Terminal pra instalar ele.

 

Estou usando uma HD particionada em GUID:

- Leopard

- SnowLeopard

- Windows

- Arquivos

 

Abs

Link to comment
Share on other sites

Ele pode estar instalado nas duas partições, mas será executado aquele que estiver na partição ativa (comando "f P" do fdisk).

 

Use um instalador do RC5, os novos não dão problema com o Windows, e você precisa do RC5 para o gerenciamento de energia, caso for usar o Auto-Patcher

http://www.insanelymac.com/forum/index.php?showtopic=227833

Link to comment
Share on other sites

Ele pode estar instalado nas duas partições, mas será executado aquele que estiver na partição ativa (comando "f P" do fdisk).

 

Use um instalador do RC5, os novos não dão problema com o Windows, e você precisa do RC5 para o gerenciamento de energia, caso for usar o Auto-Patcher

http://www.insanelymac.com/forum/index.php?showtopic=227833

 

Ok. Obrigado!

 

PS: Não há problema em estar instalado nas duas? Como posso desativar a do Leopard (desmarcar como ativa)? Pois já mandei marcar a do Snow como ativa e continua pegando do Leo.

Tenhp medo de instalar o RC5 na do Snow e continuar rodando a do Leo...

Link to comment
Share on other sites

Apenas uma partição fica ativa.

 

Talvez você gravou o boot0hfs ao invés do boot0 no MBR? Ele pega a primeira partição hfs, não a partição ativa.

 

Remova o arquivo boot da raiz da partição do Leopard.

 

Ok, vou tentar isso.

É que primeiro usei o Chameleon-2.0-RC4-r684.pkg mas não rolou... então usei a instalação manual e foi. Talvez tenha sido isso. O PKG deve ter feito isso de boot0hfs.

Aliás, o que precisa estar na pasta EXTRA da partição onde NÃO está instalado o Chameleon, além da pasta Extensions?

Link to comment
Share on other sites

É que primeiro usei o Chameleon-2.0-RC4-r684.pkg mas não rolou... então usei a instalação manual e foi. Talvez tenha sido isso. O PKG deve ter feito isso de boot0hfs.

Acho que o RC4 nem tem boot0hfs, foi adicionado no RC5.

 

Aliás, o que precisa estar na pasta EXTRA da partição onde NÃO está instalado o Chameleon, além da pasta Extensions?

Nada mais, os outros arquivos são carregados da partição do Chameleon.

 

Se você tá usando GUID pode usar o Chameleon na EFI dessa forma, pode ser melhor no caso de 10.5 e 10.6 no mesmo HD

http://www.insanelymac.com/forum/index.php...t&p=1535496

Link to comment
Share on other sites

Se você tá usando GUID pode usar o Chameleon na EFI dessa forma, pode ser melhor no caso de 10.5 e 10.6 no mesmo HD

http://www.insanelymac.com/forum/index.php...t&p=1535496

 

Mas eu não tenho uma partição extra pra isso, tenho 4 partições e a quarta (100GB para arquivos) o Windows nem enxerga, mesmo ela estando em NTFS ou FAT e, olha que ele acessa o Leopard e o Snow normalmente com o MacDrive (Windows está na terceira)...

 

Eu vi pelo Windows que o Utilitario de Disco criou umas partições não formatadas de +/- 200MB, eu acho, com nome de EFI antes de cada partição primária... é isso? É nesse local que se instala? Mas o Mac não mostra elas.

 

PS: Qual versão do RC5 posso utilizar?

Link to comment
Share on other sites

Sim, é a partição de 200 MB, veja na pós instalação desse tópico

http://www.insanelymac.com/forum/index.php?showtopic=211526

 

Instale a versão mais recente do link que eu indiquei no post #8.

 

Ok, vou fazer isso.

Só tenho uma ultima duvida. Quando o Chameleon inicia um sistema ou outro, Leo ou Snow ele carrega a pasta EXTRA referente a partição iniciada? Tipo, se eu instalar ele no EFI e deixar as kexts próprias do Leo na EXTRA deste e as do Snow na EXTRA deste, ele vai carregar automaticamente de lá? Pois estes possuem algumas diferenças, certo? Não posso deixar as kexts do Snow e do Leo na pasta EXTRA no EFI senão vai dar bug em um ou no outro, é isso?

 

Valeu!

Link to comment
Share on other sites

Abra o link no post #12, ele mostra como deve ficar a pasta Extra na EFI, todos os arquivos ficam lá, do Leo e do Snow, não fica nada na Extra das outras partições.

 

Pronto, está funcionando perfeito! VoodooMonitor ok!

 

PS: não utilizei o DSDT gerado para a P5E e sim para a Maximus Formula, que é a minha placa (tinha no AutoPatcher) e rolou.

 

Vou testar o boot do Windows agora.

 

Abs e muito obrigado.

 

VAMOS LÁ:

 

Windows nem aparece mais (tela preta com traço piscante)... não dá pra bootar o DVD pra reparar o boot após passar pelo Chameleon;

 

Painel de preferencias do RC5 travando o Painel do Mac quando clico nas abas de opções (mesmo aplicando a versão mais atual deste).

 

Abs

post-278204-1294090984_thumb.png

post-278204-1294091060_thumb.png

Link to comment
Share on other sites

 Share

×
×
  • Create New...