Jump to content

Hackintosh memory detection, 3,25 Gb


kakaru
 Share

1 post in this topic

Recommended Posts

Welcome,

 

 

 

 

I run Snow Leopard installation from grub2 without chameleon(no chameleon installed on any partition), and have memory detection problem. So I run it from grub2 only, without pbios.list.

 

System shows only 3,25 Gb RAM(in About this Mac window) like it was 32 OS but it runs 64 bit kernel (I can run 64 bit applications, "ioreg -l -p IODeviceTree | grep firmware-abi" shows ""firmware-abi" = <"EFI64">"

 

 

 

 

When I run system from tonymac's [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] it shows 4GB RAM.

 

I have DDR3 memory: 3x 1Gb, 1 x 2Gb so its 5 Gb together on Gigabyte Ga-Ex58-UD5 motherboard.

 

What could be wrong? Which kext is responsible for memory detecton? - Maybe this one is on 32bit version and thats why?

 

Thank You

 

Kuba, Poland

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...