Jump to content

Boot hangs, can't get into OSX86


OpinionatedDrone
 Share

2 posts in this topic

Recommended Posts

Okay, here are my system specs:

AMD Athlon XP 1900+ (Windows System Informaiton reports 1.6GHz)

-Instructions: MMX (+), 3DNow! (+), SSE (as reported by CPU-Z)

1GB DDR RAM (Slot 0: 512MB, Slot1: 512MB)

HDD0: 20GB Western Digital, EIDE, Pri Master

-hd0,0 Windows XP, NTFS, 20GB Partition

 

HDD1: 40GB Maxtor, EIDE, Pri Slave

-hd1,0 MacOSX86 Tiger, MacOS FS, 6.0 GB Partition

-hd1,1 No OS, NTFS, 32.17GB Partition

 

Motherboard is MSI (MS-6380)

-VIA Chipset KT266/333

-VIA Southbridge VT8233

 

BIOS brand is American Megatends, Inc ver 7.00T

 

I have two Video Cards

-NVIDIA GeForce FX 5200 on PCI

-NVIDIA GeForce MX 4000 on AGP

 

Other Devices Include:

-Pioneer DVD-RW DVR-106D

-Lite-On LTN483S 40x Max

-Floppy ( A: )

-Floppy ( B: )

-SMC EZ Card 10/100 PCI Eithernet Controller

-Creative Audio PCI (SoundBlaster)

 

 

 

Now that all of that is out of the way, here is my problem.

I used the Deadmoo image (tiger-x86-flat.img) to install Mac OS X86.

I used WinGRUB as the boot manager to achieve a dual boot with my Windows XP installation. That part works great.

Boot.ini directs to WinGrub wich directs to hd1,0 (Tiger Mac OS X86) where Darwin takes over.

 

From there I should be able to boot into OSX86, right? Well, here was my first problem, the OS kept asking me to reboot, even with the '-x' switch and the 'platform=X86PC' switch, even when combined 'platform=X86PC -x -v'. The problem was solved when I disabled my intigrated USB through the BIOS.

 

Or so I thought. OSX no longer asks me to reboot the system, but even using the switches, the boot hangs. Without any switches, I get a grey apple wallpaper with a loading circle. My HD activity light flashes for a while, then nothing. No light at all. The circle loading animation continues, but nothing happens. I left it alone all night, but, in the morning, still nothing.

 

I have tried using the switches, '-x' '-v' '-s' and '-F' and still nothing. The most progress I made was the '-s' switch, which brought me to a command line asking me if I wanted to continue loading the OS in single user mode, which I did, so I followed the on-screen instructions, and viola, it hung again.

 

It always hangs in the same spot. I get a variety of the following error messages:

/ect/rc: line ###: ## Illegal instruction /usr/sbin/__________

the numbers are always different depending on the switches I use, however, the final line is always this:

/ect/rc: line 264: ## Illegal instruction /usr/sbin/update

 

 

sorry if this is confusing at all, but the point is, it always hangs at /ect/rc: line 264: 33 Illegal instruction /usr/sbin/update (33 is sometimes 31, depending on the switches I use)

 

* the ## indicates that the numbers can be different depending on the switches used

Please help, thank you.

Link to comment
Share on other sites

 Share

×
×
  • Create New...