Jump to content

SL on Asus 1008HA notes, observations


kidslow
 Share

2 posts in this topic

Recommended Posts

I purchased an Asus 1008HA recently for the express purpose of replacing my MacBook. It's a downgrade, but the price is excellent, and I need a more powerful desktop for video and animation anyway.

 

The last generation 1008HA that came from factory with 320GB hdd, 2GB RAM, Win7 and a recovery DVD. Has Atom 280 processor, but unclear what hardware (if any) is different from the earlier generation 1008HA that came with XP or the 1005HA. On latest known BIOS.

 

I followed a combination of JoQ, Imperiopolis and TechnoTalk guides, which were all helpful in different ways.

 

  • AHCI support is b0rked. Disable it and put the internal drive in IDE compatibility mode. It seems to be the SL driver (kext) and not the BIOS itself, since it works under Win7.

Solution was to use the IOATAFamily.kext and disable AHCI support in the BIOS.

 

My install would hang on the fsck of my internal drive. Eventually it would kernel panic. A dead giveaway is that it’s difficult to even format the internal drive, with lots of spinning beach ball action. Another dead giveaway is if you “Show All Logs” in the Installer Log, it will hang just after “Checking extents overflow file.” and eventually kernel panic.

 

  • Bluetooth does not work. I cannot get bluetooth hardware to be recognized by SL. It is enabled in the BIOS, and I tried enabling and disabling. I tried the customizations to IOBluetoothFamily.kext and nothing. Doesn't recognize that I even have BT hardware.

This system purportedly comes with Broadcom Azure Bluewave BT-253 hardware, and after extensive Google searches, I am not finding anyone who reports the same issue. Maybe my bluetooth module is broken or disconnected?

 

I am in the process of reinstalling Win7 to an external USB drive to see what's up there.

 

  • It is possible to use the Recovery DVD to install Windows 7 to an external USB drive. A little trial and error allowed me to figure out the secret combination

  1. Your external USB enclosure must support only USB 1.1 or lower. It won't work with USB 2.0 enclosures. I guess the Recovery DVD doesn't include drivers.

  2. Your external drive must be bigger than 20GB. I had a 20GB that formatted to 19.1GB but the recovery process failed me because it wasn't bigger than 20GB.

  3. You must format the external drive as NTFS and choose to install to the partition. If you attempt to install to the drive, the process will fail on you with an unformatted drive.

It's taking forever, given the USB DVD to USB 1.1 HDD install, but it seems like it may work. If it does, I will have more information about the Bluetooth issue. Also, hopefully I can migrate that Win7 install to a VMWare virtual disk. Seems plausible.

 

  • Using the custom Atheros kext for Wifi. It works, but only after I put my Airport Express in 802.11 b/g compatibility mode and disabled 802.11n. I read that was necessary. The wifi seems to have intermittent problems connecting. I think it's the driver, since I have seen other reports of a similar ilk. Right after I reboot, it won't connect, and then a few minutes later it will. Once it's connected, it doesn't seem to disconnect. We are using WDS here, and that doesn't seem to complicate anything, although it may.

 

Everything else that I've tested seems to work, at least hardware-wise. I haven't pushed the OS yet with any heavy duty tasks, but working my way up to it. I am seeing some kext conflicts in the console logs, but that's because I went for the kitchen sink and installed any kext that was mentioned or included in any kit.

 

 

Questions:

 

  1. Am I the only one who has seen this Bluetooth issue?
  2. Has anyone been able to get AHCI to work?
  3. Does anyone have a custom DSDT for this system? I dumped and de-compiled the system output, and it generated a lot of errors. I don't relish the thought of getting up to speed to fix them.
  4. I'm using a chocolate kernel. Would switching to a vanilla kernel help at all?
Link to comment
Share on other sites

Still struggling with this.

 

Bluetooth adapter hardware definitely works. I checked in Linux and then noticed that it was OK under a vanilla install of OS X 10.6.0 that I've been using for recovery. It appears as the first USB port in Linux, and I can see that port in 10.6.5, but not actually the BT hardware. Current line of thought is that something in the XNU chocolate kernels is causing my problems.

 

Atheros Wi-Fi now completely broken. Can't determine why. It loads, but I can't see a single network.

 

So near and yet so far.

 

Started looking into the DSDT configuration, but that's a lot of work to get up to speed. Seems that it would likely fix such issues.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...