Jump to content

Issue With Realtek / Nvidia Audio


kamchez
 Share

1 post in this topic

Recommended Posts

Hey

 

I have searched and tried every kext possible, I've patched the Info.plist (VoodooHDA),

I've tried all of them and also tried all of the AppleHDAs.

I've tried patching using PCIMatch and PCIPrimaryMatch and even by not editing the kexts info.plst

 

Currently the only working "audio" I have is Version: 0.2.2 Patched By Thireus v.4.0

and the sound is crackling and noisy/distorted, it gets better If I move the mouse around. (the 0.21 has the same issues)

 

All other VoodooHDAs won't work at all (device not found usually) and the same goes for the AppleHDAs.

 

Im looking for a way to fix this or someone to point me in the right direction so I can patch or create my own Kext (a guide, tutorial or something) that will work for my system. (I've read a few guides and I'll post these links as well)

 

Im only interested in getting the audio jack for the headphones / internal speakers working since this is a notebook and I don't really use the sound from the HDMI.

 

I know there are a lot of talented people here and this is a great community so im sure someone will point me in the right direction so I can solve this problem.

 

My system :

 

Notebook : Asus X59GL

 

Processor Name: Intel Core 2 Duo

Processor Speed: 2.00 GHz

Number Of Processors: 1

Total # of Cores: 2

L2 Cache: 1 MB

Memory: 3 GB

 

 

System Software Overview: Installed using iATKOS v7 10.57 and upgraded to :

 

System Version: Mac OS X 10.5.8 (9L31a)

Kernel Version: Darwin 9.8.0

 

 

Audio driver :

 

Nvidia MCP79/7A HDMI 0x10de0007 (which actually is : 0x10de0ac0) | Realtek ALC663 0x10ec0663

 

Currently running : VoodooHDA.kext (Version: 0.2.2 Patched By Thireus v.4.0)

 

 

I've attached my current Info.plist (VoodooHDA) and the dumps I got by running cat /proc/asound/card0/codec#0 (and codec#3)

in linux.

 

Also the links and the guides I've read are these ones :

 

http://developer.apple.com/library/mac/#do...pci_device.html

 

http://www.projectosx.com/forum/index.php?...ic=465&st=0 (THe KiNGs guide to patching AppleHDAs)

 

Any help is appreciated, I know there are a few people out there that have the same issues I have with this specific audio device Coming up with a solution would make a lot of people happy wink_anim.gif

 

Info.plist.txt VoodooHDA.kext (Version: 0.2.2 Patched By Thireus v.4.0)

getdump.txt (Macosx dump)

linuxdump3.txt (Nvidia MCP79/7A HDMI)

linuxdump0.txt (Realtek ALC663)

 

thanks !!

and a Merry christmas to all of you

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...