Jump to content

Snow Leopard for Acer Aspire 5601AWLMi


1 post in this topic

Recommended Posts

I'm going to throw together a tutorial for other people who have this ageing beast, or laptops with similar hardware configurations, seeing as it's taken me a good couple of days to get this laptop working without the need for any external devices (monitor, keyboard, mouse)




Intel Core Duo 1.6 GHz (2mb L2, 32 Bit)


Intel 945 Graphics, 1280x800 - Device ID: 0x27a2

Intel HDAudio

Synaptics Touchpad

PS/2 compliant Keyboard

Intel 3945abg Wireless adapter


Logitech Orbicam, 1.3MP - Device ID: 0x0892


USB2.0 WLAN - Zydas1211B 802.11abg


Hardware in Italics either does not work, or has limited functionality. I'm working on it.


Things which will/should work out of the box:



DVD Drive

VGA Port

QE/CI (on external display)




First off, You'll need to connect the laptop to an external display, and plug in a USB mouse and keyboard. I installed using a retail copy of 10.6 Snow Leopard, using the Boot 132 method. If you need explanation of how to do this, look around the forum, it's pretty straight forward so far.


Once the disk has loaded up the installer, I formatted my hard drive using disk utility, into two partitions (GUID), one for snow leopard, one for time machine backup - Thank god.


Customise the install however you want it, I removed all unnecessary items (printer drivers etc.). It should take around 15-20 minutes to install a vanilla system.


Once the install has completed, use your boot 132 disk again to load OS X from the hard disk drive. If, like me, you have the 3945 wireless adapter, you won't be able to use it with security. I decided to go ahead and use a USB adapter instead of unsecuring my network.


The Zydas website no longer has drivers, and the disk that came with my adapter only had drivers for tiger, which worked in leo, but not in snow. I managed to find some working drivers for the card on this forum however, and here they are:




The next issue was getting the built in keyboard and mouse to work. For this you will need Kext Helper - http://cheetha.net/

And Kext Utility - http://www.insanelymac.com/forum/index.php?showtopic=140647


Download VoodooPS2controller.kext from the voodoo forums: http://forum.voodooprojects.org/index.php?topic=235.0

and drag this onto the Kext Helper icon. Type in your password and hit install. When it finishes, close Kext helper, and open Kext utility to clean up, and reboot.


With any luck, you should now have a working trackpad and keyboard, you can change settings in System Preferences.


You can follow the exact same instructions for installing any kexts.


Next up on the voodoo forums, find VoodooHDA and install it. The install gave me a Kernel Panic, but sound was working perfectly on reboot. again, you can change settings in System Preferences.


The next task is getting your laptop to stay lower than the temperature of the sun. On the voodoo forums, download Voodoopower.kext, and voodoobattery.kext and follow the same process as above. Now you'll have a much more comfortable experience. Voodoo battery is pretty buggy, at least on my laptop, and if, like me you spend most of your time with the battery removed, plugging it in will cause a KP, and you'll need to reboot to change over. I'm still looking for a fix.


Now, the screen is possibly the easiest part of your laptop to fix. You need to download a modified framebuffer kext from this thread: http://www.insanelymac.com/forum/index.php...199572&st=0 ONLY INSTALL THE FRAMEBUFFER KEXT. NO OTHERS.


And now you should have Wireless internet, Ethernet which works OOB, Working graphics with full QE/CI, Acceptable temperatures and no need for usb keyboards and mice.


Now, You need to install a bootloader. Most people will suggest chameleon, which is a great bootloader, but for some reason it would cause my laptop to hang at boot, with the apple logo, requiring a reinstall from a time machine image.


Install chameleon RC3 (you can find this on google as the first result), by simply following the instructions.


Before you reboot, download EFI v10.6 from here: http://www.insanelymac.com/forum/index.php?showtopic=210003


Open up a terminal, and simply overwrite the chameleon boot file with the one you just downloaded



and you'll now be able to reboot happily. I copied across the extra's from the boot 132 disk as well, but thats not neccessary.



Next up is patching your DSDT, download the patcher from here: http://www.insanelymac.com/forum/index.php?showtopic=133683 and follow the instructions there, they are far better than any I could give.


Then, if like me, you decide to copy the files from boot 132 into your root volume, open up /Extra/smbiost.plist and change the model from MacPro 4,1 to MacbookPro 4,1. Then, where it says <key>SMmaximalclock</key>, change the string to 1600. Now the about this mac window will display the correct information about your processor.


So thats as far as I have got with getting this laptop working perfectly with Snow. You can update to 10.6.5 without fear of KP, using software update, and all applications work as they should.


To remove the icon for the wireless adapter from your dock, google dockless, run it, deleting the utility from the list, and log out and back in.


Issues I'm working on (suggestions would be appreciated):


The logitech orbicam simply doesn't work. It's detected as a high speed USB device, but macam and other software simply can't use it. I'm almost sure this is a lost cause.


My USB Headset (Creative Fatal1ty) has some issues with sound. It will play to a point, after which sound will become very distorted and require unplugging and re-plugging the device. It's quite annoying, but the headphone jack works as it should, so it's not the end of the world.


Fixing Kernel Panics caused by Voodoobattery.kext


"empowering technology" hotkeys


Sleep. I know I could get this to work, but that would require changing from vanilla kernel for a feature I never use. The forum search feature is your friend if you want this functionality.


Things which I haven't tested or tried:



Card Reader




Hope this helps some of you, seeing as I had to spend 2 days searching through a countless number of unanswered forum posts until I had everything running correctly.



Link to comment
Share on other sites


  • Create New...