Jump to content

***SOLVED*** JMicron JMB363 and IDE CD-ROM drive problem


screamin
 Share

3 posts in this topic

Recommended Posts

Hello everyone,

 

Fistly, I must say, what a nice community. :D Lot's of resources, but still, I think I have a rather specific problem. Been searching trying to find an answer to for days, but no luck.

 

So, I've managed to install a retail OSX 10.6 on my PC (specs below) and managed to get it work almost perfectly. The only thing that bugs me is the (IDE) DVD-ROM drive (ATAPI, plain vanilla :(). I've used Empire EFI V1.085 for installation, and with it the DVD-ROM worked just fine. I've done some post installation steps using [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] 2.4.0 to install bootloader on HDD, along with needed .kexts, and everything worked great, except for DVD-ROM which was not working at all.

 

When booted from a HDD, the Profiler was showing two unknown devices under Serial-ATA. I later found that I need additional kext in order to get it working. So I've installed them (JMicron36xATA.kext) and hoped it would solve my DVD-ROM problem, but it didn't. And here is the strange part. Now Profiler now does show two JMicron JMB363 AHCI devices under Serial-ATA, but still no trace of my CD-ROM or my other HDD (SATA) which is connected to it.

 

And once again, when booting from a Empire EFI CD, the CD-ROM drive works perfectly fine in OSX. I've also tried turning on and off the "Enable IDE" option in BIOS, which effectively does absolutely nothing.

 

Also, if it helps, I noticed that I must have IOATAFamily.kext, otherwise the Root can't be mounted ("still waiting for root" message while booting).

 

Now, as I'm pretty new to OSX in general I ran out of ideas what to try to solve this, so any help/hint would be greatly appreciated.

 

Thanks!

 

Specs:

Motherboard: Abit AB9 Motherboard (Intel P965 chipset, JMicron JMB363)

CPU: Intel Core2Duo 1.84 GHz (E6300)

RAM: 4 GB RAM, 800 MHz, dual channel

Graphics: GeForce 9800 GTX 512 MB

HDD: 2xSeagate Baracuda 250 GB, 1 WD 640GB (all SATA)

IDE ATAPI DVD-ROM

Link to comment
Share on other sites

I managed to get this fixed. :D

 

The solution that worked for me is copy IOATAPIProtocolTransport.kext to /Extra/Extensions/, fix permisions and rebuild Extensions.mkext

 

I found this kext on the preboot image /Extra/Preboot.dmg from my boot CD. Since DVD-drive was recognised while booting from a CD I figured it must contain a kext I was missing. That one looked just right. ;)

 

It turns out that JMicron didn't have anything to do with this problem after all. So, if anyone else is experiencing the same thing with their ATAPI CD/DVD drives, give this a try.

 

Cheers!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...