Jump to content

Help with USB and OS 10.4.5 (AMD)


3 posts in this topic

Recommended Posts

Hello everybody,


I have Mac OS X Tiger (10.4.5) installed on my AMD Sempron, using the ASROCK MB running at 1.6 GHz.


The OS has been good so far but not fully useable, but good enough for experimenting, I would like to thank the Insanely Mac community for all their help so far.


My main problem right now is USB support under Tiger x86. I notice that both my Lacie external drive and SanDisk Memory stick works out of the box when plugged into the USB ports, but other devices such as my HP 840c Deskjet Printer and Canon A520 Digital camera are not detected at all.


I even installed the HP Drivers for the Printer, but still not detected when I open System Preferences > Printer & Faxes. When I click the Plus (+) sign, no printers show up, I have tried all USB ports on the system, but not luck. What could be causing this? I tried replacing the IOUSBFamily.kext (10.4.5 version file) with the 10.4.3 one in Systems/Library/Extensions folder but was denied permission, so I decided to apply the available Terminal command to the existing file and repaired permissions, I don't know if that is why my USB 2.0 external and memory stick drives now work.


Could someone enlighten me on what I might be doing wrong? I am at least Glad my memory stick is working fine so I can at least share files between Vista and Tiger more easily.


Thanks for any assistance.

Yours sincerely,

Mr. Dee

Link to comment
Share on other sites


  • Create New...