Jump to content

[Guida + WIP] 10.6.3 / 10.6.7 su Dell Precision M6400 con iAtkos S3 v2


16 posts in this topic

Recommended Posts

Questa guida è frutto dell'esperienza maturata in questo thread ringrazio tutti quelli che vi collaborano in lingua inglese.

 

le seguenti istruzioni vi dovrebbero permettere di avere mac os X 10.6.7 a 64bit con quasi tutto funzionante sull'M6400 eccetto al momento le seguenti periferiche e funzioni che rimangono Work In Progress:

(questa è una guida aperta che presenta soluzioni rapide, ma anche lascia la possibilità di approfondire e trovare soluzioni su misura)

Cosa NON funziona:

- la scheda WiFi intel (sia essa una 5100 o una 5300, al momento è una delle soluzioni più ricercate e meno esistenti )

- il bluetooth (sinceramente nessuno ci ha ancora provato nei thread che ho visto io, ne' c'è un grande interesse in merito) grazie a berserk84

- lo speedstep nativo del processore (WIP: ci sono diversi ripieghi, il mio momentaneamente è usare voodoopowermini)

- lo shutdown e il reboot (ce lo metto anche se ultimamente il mio si e spento e riavviato correttamente, perchè non ho ben capito come mai, WIP anche questo)

- la porta e-sata se collegata a caldo (ovvero i vostri HD esterni esata vengono rilevati solo se collegati a notebook spento)

 

Cosa FUNZIONA

Tutto il resto, e in maniera abbastanza soddisfacente, vediamo come:

 

Cosa serve:

premesso la macchina su cui è basata questa guida è quella nella mia signature in fondo, procuratevi:

- iAtkos S3 v2 (potete masterizzarlo ma ci metterà tantissimo per avviarsi vi consiglio di passarelo su USB, googlate per sapere come)

- il Combo Update a osX 10.6.7 (gli aggiornamenti online funzionano, ma vi consiglio di scaricarlo per praticità)

- alcuni kext che ho postati sul fondo.

 

Istruzioni:

fate partire iAtkos scegliete l'HD di destinzaione che avrete già formattato HFS+ journaled

selezionate personalizza e scegliete le seguenti opzioni:

bootloader: AsereBLN

patch: deselezionate entrambe le patch per RTC

driver: deselezionate applehda e voodoohda per l'audio (a meno che non vogliate perdervi la musica del primo avvio, basta che poi vi ricordiate di rimuovere il voodoohda.kext successivamente quando metteremo hdaenabler)

selezionate invece voodoopsowermini, ACPI, voodooPS2, voodoobattery e cardreader.

INSTALLATE

ora è il momento di patchare il DSDT:

potete fare in tre modi. estrarlo da windows, da linux, da mac, se volete approfondite nelle sezioni per farvi un DSDT.aml

io l'ho fatto da windows, l'ho patchato e ho inserito del codice per inettare la scheda video e lo shutdown/reboot

e questo è il risultato DSDT.aml

potete usare questo inserendolo nella cartella extra (tenendo presente che è basato su un intel Qx9300 che inietta una Quadro FX 3700M)

modificarlo oppure farvene uno su misura seguendo una delle varie guide sui DSDT (anche se più laboriosa consiglio quest'ultima, le stringhe che ho usato per il dst sono qui)

poi per ottenere il massimo dalle vostre quadro installate i driver che ci da invidia:

Driver: modificati per bypassare il controllo hardware

CUDA: direttamente dal sito NVIDIA

 

INVECE per avere audio e ethernet e bluetooth

installate questi kext grazie a kext utility che trovate in libreria/tools (trascinateceli sopra)

Sound_for_M6400.zip/DellBluetoothHCI.1.2.zip/Ethernet

 

per poi andare alla versione 10.6.7 al riavvio aggiornate subito a 10.6.7 col combo update. (reinstallate il kext dell'audio ovviamente)

il problema è che a me l'ethernet smette di funzionare con 10.6.7 (ma io ho una wl-167g wifi-usb-key)

se la cosa vi disturba rimanete con la 10.6.3, valutate voi.

questo è quanto.

mi scuso se ci sono errori e vi ringrazio per segnalarmeli e correggerli.

se avete migliori configurazioni o update ditemelo che aggiorno questo post.

DellBluetoothHCI.1.2.zip

dov'è la cartella extra

al solito posto.

vai in applicazioni/utility clicchi su show-hide hidden files (o qualcosa del genere) e la vedi comparire nell'HD dove hai installato X..

ricordati dopo che l'hai maneggiata di riparare i permessi nel solito modo da Terminale:

sudo -s
chown -R root:wheel /Extra/
chmod -R 755 /Extra/

ok dsdt installato e funzionante con riavvio e spegnimento :)

però non riesco a fare funzionare lan e suono ho installato con kext helper i kext da te segnalati ma non funzionano!!!

davvero? questo è strano.. sei sicuro di averli installati? prova a mettere kext utility nella dock i kext sul desktop e poi trascina i kext sull'icona. controlla anche nella cartella Sistema/libreria/estensioni per vedere se ci sono.

prova anche a dare -v -f come flags di boot , così ti ricostruisce la cache delle kext.

niente ne la lan ne l'audio ho provato in tutti i modi :-(

scusa ma hai detto che il riavvio e lo spegnimento funzionano no? e la scheda video pure giusto?

ma hai usato il mio DSDT.aml oppure ne hai patchato uno tuo?

dopo avere installato i kext la scheda di rete te la vede almeno?

ho usato il tuo dsdt! funziona riavvio spegnimento e scheda video!

la proedura è stata questa:

installo la iaktos spuntando le caratteristiche che mi hai detto

aggiorno alla 10.6.4

inserisco il tuo dsdt nella cartella extra

riavvio funziona la scheda video e spegnimento

poi provo ad installare i kext della scheda audio e di rete con kext utility e niente non funzionano! che puo essere

 

PS: ho provato a ripare permessi in tutti i modi e avviato pure in modalità -v -f

 

cmq bluetooth a me funziona!

cmq bluetooth a me funziona!

?! ah si?

il bluetooth funziona? curioser and curioser..

scusa ma mi posteresti mica la parte del tu lspci relativa ad audio ethernet e bluetooth?

per farlo se non ti ricordi vai in libreria/tools qui EvOToolsX selezioni lspci > install lspci > get lspci..

mi vien voglia di rifare tutto, pensa che invece a me ha smesso di spegnersi e riavviarsi correttamente da poco.. mah..

  • 5 months later...
allora non ho EVOtoolsX cmq ho provato a reinstallare e se non aggiorno alla 10.6.4 funziona la scheda di rete! ma continua a non funzionare l'audio ho dovuto installare voodohda ma non funziona il volume! ora provo a farti avere

lspci! per il blotooth installa questo http://www.megaupload.com/?d=DTVRS6LS! fammi sapere!

funziona il bluetooth io ho aggiornato alla 10.6.7

confermo niente più audio. credo sia necessario rimodificare applehda

e confermo che anche l'ethernet bcm5701 non funziona più, fortunatamente ho un a chiavetta wifi.

  • 3 months later...
funziona il bluetooth io ho aggiornato alla 10.6.7

confermo niente più audio. credo sia necessario rimodificare applehda

e confermo che anche l'ethernet bcm5701 non funziona più, fortunatamente ho un a chiavetta wifi.

 

Ciao,

io per abilitare la scheda di rete ho usato questa procedura:

 

- update a 10.6.7

- Cancellato / spostato la versione originale:

rm -rf /System/Library/Extensions//IONetworkingFamily.kext/Contents/PlugIns/AppleBCM5701Ethernet.kext

- copiato la kext modificata:

mv AppleBCM5701Ethernet.kext /System/Library/Extensions//IONetworkingFamily.kext/Contents/PlugIns/

 

ricostruito le cache con kext utility

 

Mattia

  • 2 years later...
×
×
  • Create New...