Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

ioregexplorer can't find my audio chip....

2 posts in this topic

Recommended Posts

Apologies for the duplicate post - just found this forum and it seems more appropriate to my audio problem - so here goes..


I built a very nice fully working hackintosh a while back and it's great - had to patch the dsdt, but got there in the end. See sig below. Learnt a lot about Mac's and hacking :-)


Now trying to build a new better Hackintosh on a asus P5Q MB with Q6600 CPU and 8800GT video.


I'm nearly there, everything works but the sound.


I've tried various kexts - but no joy, so figure I need to patch the DSDT. Sadly it seems ioregexplorer can't find my audio chip.


A few more details - I have the 2002 Juzzi bios dated 03/04/2009. I'm triple booting XP, Ubuntu and SL 10.6.4


The audio works fine in XP and Ubuntu - in XP and Ubuntu the chip gets reported as an ALC888 (not ALC1200 as per the MB spec). So I guess the patched BIOS is ok.


I've extracted the DSDT while in Ubuntu and de-compiled it - no obvious sign of HDEF.


On my original working Hackintosh the HDEF shows under AppleACPIPCI as HDEF@1B - no sign of anything like that on the new machine.


I'm running Chameleon RC3 fully installed but suspect it might be ignoring my patched DSDT - but shouldn't IOregexplorer find the HDEF chip with or without a patched DSDT ?


In Extra/ extensions I have the following:





IOAHCIBlockStorage Injector.kext





What am I missing here to get the audio chip recognized and operating ?


Do I need to do anything to make sure Chameleon takes notice of my patched DSDT ?


BTW - posting this from my nearly perfect new Hackintosh :-)


Thanks again guys (I hope)

Share this post

Link to post
Share on other sites

A little bit of progress.


So i generated a DSDT.aml under Ubuntu and implanted it into /extras and then / - same result, no audio detected.


So I deleted it then ran dsdt patcher in OSX which generated a patched DSDT.aml which is significantly different to the one from Ubuntu.


I put this patched DSDT.aml into / and inserted an AppleHDA.kext which seemed like the right one.


Hey presto ioregexplorer finds the HW and the sound works - sort off.


It's a bit quiet and distorted but at least there is sound.


Tried quite a few different Apple HDA.kext's - all have the same problem, distorted audio.


I think I'm going to try and fine tune the DSDT.aml for my particular set up. Stay tuned.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.