Jump to content

Dual boot, vanilla osx and win7


8 posts in this topic

Recommended Posts

OK, can someone point in the right direction here?

 

I have a 1TB HD. I have 2 x 500 GB partitions, OS X on one and Win7 on the other. I installed Win7 first (2nd part.) and then installed OS X second (1st part.). I installed the latest Chameleon RC5 pkg installer and when I went to reboot, I just got a "Loading Operating System ..." followed by about 20 periods...and no nothing. Now, I can boot either OS, with [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] Supported but the bootloader isn't loading. I went into fdisk and made the OS X partition "active" and still... nothing.

 

Obviously, I am missing something. Can someone fill me in on what I'm missing?

 

Thanks!

Link to comment
Share on other sites

As far as I know, it doesn't matter. I can boot with the boot CD but if the hard drive tried to load Chameleon...it never starts and therefore, it just hangs.

 

Some people feel comfortable with the Windows boot manager and others use Chameleon. What I'm trying to avoid altogether, is booting with the Windows boot manager, then selecting OS X, and then being taken to the Chameleon boot loader, in order to launch OS X. There has to be a way to do this but I'm just missing some steps.

Link to comment
Share on other sites

I might be wrong, but shouldn't Windows always be on the first partition?

 

It doesn't have to be. As long as Windows is on a primary MBR partition (on BIOS-based systems), it should be able to boot. I've never had problems booting it on any primary partition.

 

That said, I have seem reports from people who claim that Windows is finicky about which partition it's on. Most of these, however, seem to be from people who are using hybrid MBRs, which most people don't understand. IMHO, it's likely that problems in the hybrid MBR setup unrelated to the position of the Windows partition are at fault in such cases.

Link to comment
Share on other sites

  • 3 weeks later...

Well, after about 2 weeks or so days of waiting patiently for my Corsair PSU to be RMA'ed, I have a machine again!

 

I've decided to say 'screw it' and will wipe the primary drive and will install both OSes on their own HD's this week. Win 7 (first) on the 2nd drive and then OS X on the 1st drive and then Chameleon bootloader.

 

We will see what happens.

Link to comment
Share on other sites

  • 2 weeks later...
 Share

×
×
  • Create New...