Jump to content
InsanelyMac Forum
  • Announcements

    • Allan

      Solution to create a topic or post.   04/24/2018

      Hello guys. The majority of you are having issues to create a topic or post here. This are a problem with our current theme InsanelyMac.  Now the theme will be the Default IPS. Sorry for any inconvenience.

Successful Leopard 10.5.7 / Vista dual-boot on HP DV5-1054tx

Recommended Posts

Hi all,


Having relied on other people experiences in order to get this install to work, I thought I'd give something back, especially seeing as there are so few references to working installs on a HP DV5-1054tx. I installed iAtkos v7 both on a USB drive and on a partition of my internal Win Vista drive, and as far as I can tell the only thing that isn't supported is the Intel Pro 5100 wifi (for which there'll hopefully be a working kext soon...). I didn't need access to a Mac for disk preparation. It didn't require any messing with code or custom kexts.


Hardware as follows:

HP DV5-1054TX Notebook - FU647PA

PROC : Intel Core 2 Duo T9400 2.53 GHz, 1066MHz FSB, 6 MB L2 cache

CHIPSET : Intel PM45

MEM : 3072MB DDR2 Mem, 2 DIMM's (Max upto 8GB)

GRAPHICS : NVIDIA GeForce 9600M GT with 512MB Dedicated graphics Mem

NTWK : Intel Wi-Fi Link 5100 & BT, Intg 10/100/1000 Gigabit E'net LAN

PORTS : 4 USB 2.0 (4th shared with eSATA port), eSATA Combo, VGA, HDMI

Pre-installed OS : Win Vista Home Premium (32-bit)


After failing miserably at a snow leopard install in Virtualbox (I think it requires 64-bit windows, right? although most tutorials forget to mention that...), I successfully installed iAtkos v7 (OS X 10.5.7) first onto an 8 gig USB thumb drive, and later onto a partition of the internal drive Vista is installed on. I made the move ot the internal drive because although 8GB was enough for the install, it wasn't enough to update to 10.5.8). It pretty much worked out of the box... there was the small issue of a corrupted Vista install after installing OSX onto my internal drive... but this was easily fixed (below).


I burnt the .iso to a disc and used this for each install.


USB INSTALL (dual boot)

(Of course this is all at your own risk, but you knew that before you came here, right?)


For USB install, I formatted the thumb drive as NTFS in Vista (give it a name so you can identify the volume later), and then rebooted with the iAtkos disc in the drive, hit esc and then F9 for boot options and selected the disc. The iAtkos installer took a while to load... be patient... Once it loads, click 'the button' as requested, and on the next dialog, click the Utilities menu and go to Disk Management (or w/e it's called), select your thumb drive at left (don't select the one with the volume size next to it, but rather the one below that... make sure you don't select your internal drive here - you'll be erasing the selected volume!!). Hit 'Erase', select "Mac OS X Journaled" as the format and give it a name again. Then hit Erase again... or whatever it says... I really don't remember... It should only take a couple of seconds, then close out of the disk management utility (either through the menu or with the X), and you should be back at the dialog box where you need to Accept, or Agree, or Confirm, or... whatever. Select your thumb drive volume to install to, and click next, then CLICK CUSTOMISE. Here's where you select drivers etc. that are relevant to your system. Here's what I selected (wording might be slightly wrong... doing this from memory/notes):


- check iAtkos v7 Main system

- check Chameleon 2.0 (in Bootloader)

- check Extra, DSDT, Disabler (in X86 Patches)

- check Apple Decrypt (in X86 Patches > Decrypter)

- check 9.7.0 Voodoo kernel (in X86 Patches > kernel)

- check NVEnabler (in drivers > VGA > NVidia > Enablers)

- check Voodoo HDA driver (in System > sound)

- check Voodoo PS/2 driver (in System > PS/2 mouse/keyboard ... NB: trackpad and USB mouse will still work, don't worry)

- check laptop battery (in System)

- check Realtek R1000 (in Network > Wired > Realtek)

- check Post-install actions


If your system is different, then obviously you might need to select different options...


Click Done, then install.


If you already verified your disc's checksum, then skip the disc verification, and sit back and wait... and wait... until your HP reboots. The progress bar stops at times, for a LONG time (10-20 mins... or more), and at times the disc stopped spinning. Just give it time...


When your laptop reboots, hit esc and then F9 again (if you miss it, it'll boot from the disc again, which just means you have to wait for the installer to load then quit out of it, or else ctrl-alt-del to reboot again). At the F9 menu select boot options and choose your thumb drive to boot from. The bootloader will show, with the chameleon at the top, and at this stage if you hit a key you can select which volume to boot from. Boot from the thumb drive, and you should be in business. The first load can be a little slow again, so be patient, and you will be rewarded with some installation configuration screens. Fill them in... when you get to the registration screen you can press alt+q and say 'skip', which will take you to next dialog. Once you've filled everything in, you should see the OS X welcome animation... if it's the middle of the night and you're doing this quietly in bed next to your significant other, you should plug in some headphones, because it's LOUD, and the volume touch-buttons don't work just yet (in fact I'm not sure if I really got them working at all, but whatever). I didn't get any errors during this whole installation. A couple of times through the installation (I repeated it two or three times with different customisation options) the iAtkos installer couldn't see my thumb drive, and when that happened I just had to go back to Vista and format it again as NTFS. Anyways, now you have Leopard 10.5.7, and your mouse, trackpad, sound, ethernet, webcam and usb ports should be working fine, and you should also be running at 1280x800. If your USB drive is big enough (i.e. 16GB or more), you can wire up to network and run Apple update to update to 10.5.8. You should also be able to see and access any external hard drives as well as your Vista volume (mine was labelled "untitled"... just be aware this is your C drive), and recovery volume, if you have one.


Vista should still be working fine. To get into Vista, take the install disc out of your drive, reboot, and as long as thumb drive is lower priority in boot options (in your bios) than internal hard drive, you should boot straight into Vista. If your thumb drive is higher priority, then at the Chameleon bootloader you can press a key to select Vista, or else change boot order in bios, or esc and F9 to get to boot options and select the Vista volume.



(Of course this is all at your own risk, but you knew that before you came here, right?)


Ok, so if you're like me and you want more space for your OSX install, you can install it alongside Vista on your internal hard drive.


Before you go down this path, it's a good idea to have a Vista bootable repair disc on hand, even if you have a recovery partition. That way if your Vista install is corrupted by the OSX install, you'll be able to get to a command prompt to fix things up (it happened to me, but is an easy fix). If you don't have a Vista repair disc, you can download a legit one for free from Neosmart. Burn this to a CD/DVD (Google and download ImgBrn if you don't have a suitable image burner... but then you probably wouldn't be here if you didn't have a suitable image burner, right?).


You first need to partition your drive... this can be a bit of a pain in the butt. First, make sure you have enough space free on the drive you want to install OSX onto (enough = however much you want, but at least 8GB, I did 20GB). So delete your porn and MP3s and free up some space. Now you want to create a new partition to install to. In Vista, right-click on My Computer, and click Manage. Double-click Disk Management and then Storage. Right-click on your Vista volume (probably C drive), and select Shrink Volume. It'll calculate how much space it can put aside for you. More often than not, this will be a number much smaller than your actual free space. For me, I had 30GB free and it told me I could shrink 2GB... this is because system files are scattered throughout the free space. You need to defrag. I tried a few defragmenters, including freeware Defraggler and Auslogics Disk Defrag, but I think the one that really worked for me was Raxco PerfectDisk 11. This one's not free but there's a 30-day fully functional trial available from their website. Install it and run it, and do a SmartPlacement Defrag on your hard drive. Once that's done (it took probably a couple hours on my laptop), run a Free Space Consolidation Defrag, and once that's done click Boot Time at the top of the screen, and tell it to defrag at next reboot (this will defrag your system files, and this step is the one that made the biggest difference for me). Then reboot and let it do the boot time defrag. Once you're back in Vista, right click on My Computer, then manage, disk management, storage, and right click your drive again, tell it to shrink volume, and see if it's being a little more generous. If not... Google is your friend. If so, select the size you want for your OSX volume (I chose 20000MB), and click ok. Once it shows next to your C drive, right click it and choose New Simple Volume. Give it a name, format as NTFS, and give it a drive letter, then continue. Now reboot with the iAtkos v7 disc in your drive, boot from the disc, and go through the same motions outlined above for the USB install. (While the installer was loading, I got the 'circle with a line through it' AKA 'prohibitory sign' AKA 'no entry sign' AKA 'no smoking sign' (lol) but I just waited and waited and the installer loader anyways.) This time of course when you go to Utilities > disc manager, you want to erase your new partition (NOT your windows partition... duh). Use your brain, and use the USB install instructions above as a guide, and you will be at the OSX desktop in no time. Now, when you reboot and try to boot into Vista, you will possibly (probably) get an error saying that your Vista install is corrupt. DON'T LOSE YOUR {censored}! I think we'll get through this together... and if we don't I accept no responsibility :wacko:


Boot from your Vista repair disc (or reboot, esc and F9 to try and boot from the recovery partition if you have one). Once in the repair thing, it might automagically detect a problem with your Vista install, or it might not. Just click through that screen (I told it not to try and repair my install.. maybe it would have worked, I dunno), and go to the command prompt.


At the command prompt, type the following commands:


SELECT DISK 0 (this assumes you only have one hard drive connected, if you have more, use LIST DISK to identify the disk number of the disk you should be selecting (i.e. your disk with vista installed).

SELECT PARTITION 1 (this assumes your partition with vista installed is partition 1, you can confirm this with LIST PARTITION)






SELECT DISK 0 (again, assumes your hard drive with vista is disc 0)

SELECT PARTITION 2 (assumes your OSX partition is number 2)




Then restart, and everything should be running just fine again.


Shout out to Orteginho on Youtube for the above fix (sure, others probably have written it up too, but he's the first I came across).


Now on boot, Chameleon bootloader will automatically appear, and if you want to boot into windows you need to manually select it through the bootloader (press a key and arrow across to the Vista volume).


I hope this helps someone... it's probably not new information for most people, but it's a consolidation of all the steps that I had to go through, which I wasn't able to find in one tidy tutorial. I also just wanted to let you know that iAtkos v7 works fine on HP DV5-1054tx (at least on mine!).


I'd attribute all the posts/tutorials that helped me along the way, but there were so many and I don't really have time to go back and find the relevant ones in my history/bookmarks.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • Try this folder: EFI_24042018.zip If you're booting to the installer, while in clover menu, go to options > graphics injector and change ig-platform-id to 0x12345678
    • both, because as i have seen you don't have FakeSMC plugin's,  but you still need some things in config.plist 
    • Test this https://www.dropbox.com/s/j800jusbzh370ox/Ace - EFI.zip?dl=0 Let me know how it goes.
    • Would this help solve my low scores on my machine or just my video laggy issues?
    • Hello artur_pt,   What changes did you make and also I have a new DSDT that I have uploaded (V0.2), maybe we can work with that?   Thanks, Q Hello Allan, Below is the link to my EFI Folder and i ran another debug tool created by "black.dragon74",  but i have attached the output from that tool as it also takes the copy of my IOREG. Please note that, this download is considered "V0.2" because I have used my own DSDT that i have managed to patch with the fixes below:   - Asus G75VW Battery Patch (supposed to work on Asus Q550LF) - SMBUS Fix - Fix _WAK Arg0 V2 - Fix Mutex - Fix Parseop - Added EMIyDinEsH Patch for AsusFN keys. -Add IMEI -Add MCHC   With the above fixes, I have keyboard backlight working along with the fn+F3, fn+F4 working to increase/reduce keyboard backlight. Also the battery meter now works if i unplug the laptop. But if i plug it back in then that change is not registered and the battery meter doesnt update in the menu bar. The battery is meter does not show unti li do not unplug the laptop so i am assuming DSDT needs more fixing. No screen brightness/slider and DGPU still seems active(powered on).   Also the SSDT-DGPU you provided, i renamed it to SSDT.aml and dropped it in the same folder with my DSDT.aml, is this right? because now when i boot, i can still see the Nvidia card from my "system report" and systems temps are high 60 celcius so im assuming its not working?   https://drive.google.com/open?id=1GsUReWE5cmWyN7ClyZkkNmsynUBTk6pK   Thank you all