Jump to content

Kakewalk EP45-DS3R Workaround?


1 post in this topic

Recommended Posts

For the last four days, I have been trying endlessly to install Snow Leopard in a way that harmonizes all of my hardware. So far the best way to do this has been to boot either the Retail DVD or SnowOSX Universal version of Snow Leopard through Kakewalk.


As I am currently running a Gigabyte EP45-DS3R, a board not supported by Kakewalk, I have tried two different approaches, both of which have yielded two satisfactory results.


My first approach was to install Snow Leopard with Kakewalk, and choose the install configuration for the EP45-DS3L as it seemed (on the surface), to be a close match to my motherboard. With this package, I was only required to install kexts for two pieces of hardware: my onboard sound, and wireless network adaptor. As I am using a D-Link DWA-522 network adaptor, I have been depending on AtherosFix.kext and IO80211Family.kext, which have worked perfectly on the EP45-DS3L configuration. Sadly, though, I was unable to get my ALC889A drivers to work, and have been dependent on VooDooHDA.kext to get my sound going. Unfortunately, the VooDoo drivers seem to bring my system to a staggering halt after an hour of uptime, lagging my mouse and making the system unbearably slow.


In an attempt to find an alternative to my sound issue, I came across a post that proposed using the Kakewalk EP45-UD3P installer as it was compatible with the ALC889A hardware, while the DS3L used 888. After using this approach on a fresh install, my sound was up and working. Despite this good news, the AtherosFix seemed to no longer work, and restarts and reboots have become unstable, thus leaving me no further ahead.


Can anyone share their secrets to getting the Gigabyte EP45-DS3R to function properly? It would be ideal to extract the ALC889A audio drivers from the UD3P package and overwrite them into the DS3L.

Link to comment
Share on other sites


  • Create New...