Jump to content

Lenovo Thinkpad Edge


4 posts in this topic

Recommended Posts

Salutations, I am new here, and as goes with the territory--I am completely naive to the OSX environment.


My goal is to piecemeal the necessary steps to upgrade my current system, the aforementioned Thinkpad.


I've noticed by overviewing a handful of guides 132 Boot, Chameleon, and a few other Retail boots that much of these guides give you a general guidelines on their specific method, but many of the "tools" used are ones that require equally lengthed elaborations; or more specifically, these "tools" are case specific, and also superfluous outside of preference, i.e. the maker of the guide used the methods not because they worked, but because they worked in a way they preferred, despite being able to arrive at the same destination. While I had only gleaned over these articles, they do little to "point you in the right direction".


So I suppose that is where my "dilemma" comes in.


Why should I choose one method over any other?


Below are my current hardware specifications:


Brand: Lenovo

Model: Thinkpad Edge xx

Variant: 14 (the "xx")

Processor: Intel M330 i3 Core

Graphics: Intel Graphics Media Accelerator HD

Memory: 4GB DDR3 @ 1066MHz

Storage: 500GB 5400RPM SATA HDD

Networking: Intel Wifi Link 1000BGN

Media: Standard DVD +/- RW with DL player

OS: 64-BIT Windows 7 Prof.



From the reading I have done I have noted that many people have issues with Intel based GMA, although mostly the 4500 series (if i'm not mistaken)?


Also another contention of users is that broadcom based wireless card seem to function (a Dell card by Broadcom is recommended more than once by users in that event, but only with the Intel 5100, I am unsure as to whether or not the Intel 1000 faces the same conflict)



While I DO have access to another computer, I cannot boot from another drive (since it's a laptop), I cannot reinstall Windows (do not have OS disk, just recovery software which formats drive by default), and I have a 16GB Flash drive in case there are some specifically good tools / utilities to boot from drive. I also have the original (retail) OSX 10.5 disk, and the Snow Leopard upgrade software. I also have blank media (DVD's) to either mount an ISO on, or customized bootable environment.


I have read a little in regards to EFI, but from what I understand it is essentially a moot feature, since it's "workable" if your computer is solely BIOS reliant?





So the question now is, where to start?


(Please note that I am asking for advice and perhaps a reason or two as to why one guide is better than another, and what tools you prefer, and I'll base what I try after that)

Link to comment
Share on other sites

  • 5 weeks later...

I went off the edge and decided to go with Kalyway, I did some research, and I wanted to see how it booted non withstanding the extraneous efforts of collecting hardware specific kexts.


From my interpretation, the software should boot, although not all items are guaranteed to work--those including sounds, and odd fixed resolutions--I just wanted to get OSX up and up before trying at 100% installation.


I was running the 9.2.0 version (Darwin?) and I pressed F8 when to loader came up.


I tried several different commands, while some users typed in -V, others on youtube - Vanilla / Vanila? and the READ ME with the Kalyway was -S (for Single user I think?)


ANYWHO, sometimes I'd get a Kernel Panic (I'm guessing because it would just hang at certain prompts) I toyed with BIOS and finally when typing in -S I was able to get the loader to progress somewhat, several spins off the DVD until it stopped.


The final text read "-sh-3.2#"


Above it, it said type Exit to end or something, but the block at the end did not move nor did any text input on the screen.


I restarted and voila, I get a screen with an ugly ass Chameleon and a countdown saying "Press any key to start up from Mac OSX Install, or press F8 to enter startup options"


When I hit enter / let it time out it goes as if to boot from my OSX partition, but it leaves me at a blank screen with a flashing cursor in the upper left corner (obviously no OS exists on the partition)


So what I'M trying to figure out is WHAT / WHERE to go from here.



It seems SOME of the guides are very limited as to what parameters one can install the OSX media. One requires XP to be installed and others to already have OSX on the drive (which is retarded enough as it sounds--since if one already has OSX, why would one want it on a PC?)


anyways, maybe by some glimmer of hope SOMEONE will read this and be able to assist me because I am at a loss here.


As I said, I have a 124MB Flash drive, I have plenty of blank Media, I have a retail copy of OSX Leopard 10.5 / Snow Leopard Upgrade, and I DO have an OS (Windows 7) on the laptop, which is negligible whether or not it is accessible after the OSX install--to me at least.



So I reinstalled the Kalyway 10.5.2, and I just "Erased" (Formated) the enter HDD Volume, including any traces of Windows 7 that remained using the disk utility and also I unchecked Vanilla Kernel (since for some reason both Vanilla and Sleep were selected)


About 30 minutes later, install goes through, I reboot. and AWESOME, It doesn't crash instantaneously on the grey Apple screen. The loader spins for a bit and then it begins to start up OSX for the First Boot setup.




My laptop onboard keyboard does not seem to be detected! (I should note that it does not work either when in the Kalyway modified Installer either, so when I formated I couldn't rename my drive anything besides "Untitled")


I've been trying different boot commands, -s, -f, -x. But I still get the Apple prompt saying I need to plug a keyboard in before continuing. Rather than take one step forward and two steps back by plugging in an external as my only option...what could be causing this issue?


Will I need to make a whole new disk with a custom Kext for the keyboard? (Because I have no clue)


On a side note, the trackpad as well as the Lenovo trackpoint nub work perfectly fine...no word on Audio / Wireless since I have yet to run em'


Link to comment
Share on other sites



I've gone ahead and will be attempting to upgrade to SL


I have used a method I found utilizing a bootable USB HDD (flash drive) with the SL image and every time I get it to load, it comes to an Apple logo on a grey background and suddenly restarts--ad infinitum.


No really sure what to do now...



I know this is now about SL 10.6.x but since I still have yet to have permissions to new post in other forum areas, I'll just update in here...hopefully now someone will be able to assist.


Link to comment
Share on other sites

  • 8 months later...

  • Create New...