Jump to content
InsanelyMac Forum
Sign in to follow this  
TennisGeek

GIGABYTE Radeon HD 4850 - GV-R485MC-1GI

Recommended Posts

http://www.insanelymac.com/forum/index.php?showtopic=173684

に 10.6 で Gigabyte 4850 で動作しているようです。

 

nVidia カードがあれば、インストールはとりあえず nVidia で行って、インストール終了後、 kext を設定してリブートして試す必要があると思います。

 

上のトピック、わからないようでしたらここで質問してください。 よろしく。

 

-- TG

 

 

:wacko: 今日は。

GA-G45M-UD2HにQ8400またはE6850, 4GB RAM, GF9800GTを使用して、Kakewalk+リテールSnowLeopard10.6を使いSLをインストールしていますが、未だにRADEON4850でのインストールに成功した事が有りません。

この4850はGIGABYTEのFanless, 1GBでfanの数が減って静かに運用出来る事を期待していたのですが、[url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] ATIを使ってもSLを入れたとたんに動きが止まってしまいます。

最新のiMacではシステムVGAが4850の筈なのに何でこうなってしまうのでしょう。

 

何か秘訣の様なものが有ればお教え頂けると有難いのですが。

ひょっとしてリテールSLは10.6.2以上でないといけないとか。

Share this post


Link to post
Share on other sites
Advertisement

ところで、 Chameleon は何を使ってます?

 

新しい Chameleon だと、 ATI カードの自動検出をしてくれるので、 "/boot" だけを新しいものにして、 "GraphicsEnabler" "Yes"を /Extra/com.apple.Boot.plist に加えるだけで動作する可能性があります。

 

-- TG

 

http://www.insanelymac.com/forum/index.php?showtopic=173684

に 10.6 で Gigabyte 4850 で動作しているようです。

 

nVidia カードがあれば、インストールはとりあえず nVidia で行って、インストール終了後、 kext を設定してリブートして試す必要があると思います。

 

上のトピック、わからないようでしたらここで質問してください。 よろしく。

 

-- TG

Share this post


Link to post
Share on other sites
http://www.insanelymac.com/forum/index.php?showtopic=173684

に 10.6 で Gigabyte 4850 で動作しているようです。

 

nVidia カードがあれば、インストールはとりあえず nVidia で行って、インストール終了後、 kext を設定してリブートして試す必要があると思います。

 

上のトピック、わからないようでしたらここで質問してください。 よろしく。

 

-- TG

 

今日は。

 

ご教示有り難う御座いました。

 

確かに、書いてあった

通りにやってみた所、表示はされましたが、ちょっと残念な事が。

解像度がXGA固定でUXGAや他の解像度には変更出来ませんでした。

 

apple.boot.com.plistをいじってやっても駄目な様です。

 

しかし、このやり方ではインストール時には一寸使えませんね。

4850が動くのは確認出来たのですが。

 

chameeonの最新版を使ったbootloaderを使うと解決出来るのでしょうか?

まだまだ、修行中です。

Share this post


Link to post
Share on other sites

モニターが検出されていないということは、 ATI 4850 のドライバがロードされていないということだと思います。 つまり、 VGA で動いているのだとおもいます。 システムプロファイラーでみるとわかります.

 

リンクされたトピックでは Quartz Extreme / Core Image (QE/CI) とも動作しているということなので、解像度なども正しく動いているはずです。 あなたのところでは動いていないと思います。

 

Terminal で

ioreg -lw0 > ioreg.out

 

として、 ioreg.out を ioreg.out.zip にして添付してください。

io registry のダンプです。

 

com.apple.Boot.plist に EFI string をいれるのと同等のことを Chameleon でするので、まずは最新の Chameleon をつかうことをお勧めします。

添付したので、解凍した後、 terminal で、

su install ./boot /

でコピーしてください。

com.apple.Boot.plist には

	<key>GraphicsEnabler</key>
 <string>Y</string>

を追加してください。

 

Ubuntu を使って、 DSDT の取得と、 lspci を使って PCI ID (PCI registry) をとると、カードとドラーバーのマッチングを試せるので、やってみてください。 やり方は書いてあります。

 

-- TG

 

 

今日は。

 

ご教示有り難う御座いました。

 

確かに、書いてあった

通りにやってみた所、表示はされましたが、ちょっと残念な事が。

解像度がXGA固定でUXGAや他の解像度には変更出来ませんでした。

 

apple.boot.com.plistをいじってやっても駄目な様です。

 

しかし、このやり方ではインストール時には一寸使えませんね。

4850が動くのは確認出来たのですが。

 

chameeonの最新版を使ったbootloaderを使うと解決出来るのでしょうか?

まだまだ、修行中です。

boot.zip

Share this post


Link to post
Share on other sites
モニターが検出されていないということは、 ATI 4850 のドライバがロードされていないということだと思います。 つまり、 VGA で動いているのだとおもいます。 システムプロファイラーでみるとわかります.

 

リンクされたトピックでは Quartz Extreme / Core Image (QE/CI) とも動作しているということなので、解像度なども正しく動いているはずです。 あなたのところでは動いていないと思います。

 

Terminal で

ioreg -lw0 > ioreg.out

 

として、 ioreg.out を ioreg.out.zip にして添付してください。

io registry のダンプです。

 

com.apple.Boot.plist に EFI string をいれるのと同等のことを Chameleon でするので、まずは最新の Chameleon をつかうことをお勧めします。

添付したので、解凍した後、 terminal で、

su install ./boot /

でコピーしてください。

com.apple.Boot.plist には

	<key>GraphicsEnabler</key>
  <string>Y</string>

を追加してください。

 

Ubuntu を使って、 DSDT の取得と、 lspci を使って PCI ID (PCI registry) をとると、カードとドラーバーのマッチングを試せるので、やってみてください。 やり方は書いてあります。

 

-- TG

 

:rolleyes: 今日は。

 

GF9800で動かしていたSLですが、オークションで4870がそこそこの値段で手に入ったのでさあどうなるかと思って

挿して恐る恐る起動して見た所、何とあっさりと起動し、システムからも4870として認識されていました。

4850と違って何の不具合も感じません。

 

色々とご教授頂き有難う御座いました。

私としてはこれで常用として4870をビデオシステムに稼働させる事が出来ました。

NVIDIAとATIでは色合いが違うと聞いていたのですが、目も悪くなったか余り違いは判りません。

4850は2枚有るのでこちらはCrossFireとしてWindowsででも使ってやろうと思っています。

 

ただ、SL10.6のインストールは9800GTで途中から4870ですのでインストール当初から4870で動作するかの検証は

取れていませんが、交換再、起動時の認識のされ方からすると、多分大丈夫ではないかと思われます。

 

以上、ご報告まで。

Share this post


Link to post
Share on other sites

ちなみに、 4870 は、どこの製品ですか?

私も graphics を nVidia 8500 からアップグレードしたいので、正確な名前を教えていただけると幸いです。

 

-- TG

 

:D 今日は。

 

GF9800で動かしていたSLですが、オークションで4870がそこそこの値段で手に入ったのでさあどうなるかと思って

挿して恐る恐る起動して見た所、何とあっさりと起動し、システムからも4870として認識されていました。

4850と違って何の不具合も感じません。

 

色々とご教授頂き有難う御座いました。

私としてはこれで常用として4870をビデオシステムに稼働させる事が出来ました。

NVIDIAとATIでは色合いが違うと聞いていたのですが、目も悪くなったか余り違いは判りません。

4850は2枚有るのでこちらはCrossFireとしてWindowsででも使ってやろうと思っています。

 

ただ、SL10.6のインストールは9800GTで途中から4870ですのでインストール当初から4870で動作するかの検証は

取れていませんが、交換再、起動時の認識のされ方からすると、多分大丈夫ではないかと思われます。

 

以上、ご報告まで。

Share this post


Link to post
Share on other sites
ちなみに、 4870 は、どこの製品ですか?

私も graphics を nVidia 8500 からアップグレードしたいので、正確な名前を教えていただけると幸いです。

 

-- TG

 

:) 玄人志向のRH4870-E512HW/HDと云うやつでヤフーオークションで7,500円也で落札したものです。

SilverStoneのSST-GD05Sとか云うケースに入れていますが、ファンの音も殆ど気になりません。

 

ホントにこんなに簡単に動くとは夢にも思いませんでした。

駄目だったら、再インストールだ!と思いながら入れて見たのですが、9800GT並です。何もする必要が有りませんでした。

 

:D 玄人志向のRH4870-E512HW/HDと云うやつでヤフーオークションで7,500円也で落札したものです。

SilverStoneのSST-GD05Sとか云うケースに入れていますが、ファンの音も殆ど気になりません。

 

ホントにこんなに簡単に動くとは夢にも思いませんでした。

駄目だったら、再インストールだ!と思いながら入れて見たのですが、9800GT並です。何もする必要が有りませんでした。

 

調子に乗っておまけにSST-HDDBoostを入れたらどうなるのだろうと思い、入れた所こちらもあっさりと動き出してしまいました。 初期のバージョンではブートエラーで駄目だったのですが。

boot時間とか、プログラムのスタート時間とかを測れば効果の程が分るのでしょうが、こちらも「あら、動いちゃったよ」でさし当たりそのままになっています。早い様な気はするのですが、夢かなあ?

Share this post


Link to post
Share on other sites

情報、ありがとうございます。

 

4870 は、以前の 27" iMac に載っていたはずなので、動作するとは間違いないのですが、ドライバがロードするのはラッキー!

日本にすんでいないので、玄人志向は買えないですね。

 

-- TG

 

:blink: 玄人志向のRH4870-E512HW/HDと云うやつでヤフーオークションで7,500円也で落札したものです。

SilverStoneのSST-GD05Sとか云うケースに入れていますが、ファンの音も殆ど気になりません。

 

ホントにこんなに簡単に動くとは夢にも思いませんでした。

駄目だったら、再インストールだ!と思いながら入れて見たのですが、9800GT並です。何もする必要が有りませんでした。

 

 

 

調子に乗っておまけにSST-HDDBoostを入れたらどうなるのだろうと思い、入れた所こちらもあっさりと動き出してしまいました。 初期のバージョンではブートエラーで駄目だったのですが。

boot時間とか、プログラムのスタート時間とかを測れば効果の程が分るのでしょうが、こちらも「あら、動いちゃったよ」でさし当たりそのままになっています。早い様な気はするのですが、夢かなあ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×