Jump to content

10.6 retail on Acer 5738g ATI 4570

4 posts in this topic

Recommended Posts

Really getting fustrated trying to install OSX on this laptop. It's an Acer Aspire 5738g with the ATI mobility 4570 (512mb) graphics card.


I've read hundreds of guides and pages online about this, but there must be something the guides aren't saying because i get the same issue every time.


I've tried getting a working USB bootloader sorted but my laptop refuses to boot from a USB just giving a black screen with a blinking line at the top left... this would be my prefered method so i dont have to go through so damn many cds trying to get this working but i've since given up on this


Bootloaders i've tried on CD:


The latest chameleon RC4 bootloader

[url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] ATI

[url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] Supported


Results: Always the same, i burn the ISO to CD, everything works fine when i boot from a CD up to the Chameleon Screen where you eject the disk, insert the retail snow leopard disk press f5 to rescan and boot from the Mac OSX Install Disc. After this i get the Apple Symbol with the grey loading spiral then it works for a bit and produces a grey grey screen, then does nothing.


I've tried editing the com.apple.Boot.plist to change Graphics Enabler from "Yes" to "No" but this has no affect, same outcome...


So what's the problem? Is there anything else i need to add to the ISO before burning the bootloader to CD for my system? If so can you be SPECIFIC in your replies what i have to do and how i do this don't just say "oh you need to add such and such kexts".


Edit: Essentially i'm looking for an ISO of a bootloader for my system that won't just give me the f*ckin grey screen when booting from my Snow Leopard Retail disc.

Link to comment
Share on other sites



Additional information its a PM45 Mobile chipset, core2duo T6600 which i've read should work with the bootloaders i've tried so it must be the graphics card that's causing the grey screen... is that anyone that can tell me how i modify kexts for the graphics card, there is a 3650 mobility on kexts.com but i dont know the code to modify, what program to do this with or how to add it to the ISO, do the kexts that live in preboot.dmg get loaded into the memory before you insert the Snow Leopard retail dvd?


also heard of people starting in -v (verbose mode and being able to type things into the linux kernel to solve their woes, but i also don't know how this is done). Any help guys?

Link to comment
Share on other sites

  • 3 weeks later...

Yo Vips,


I have a Dell Studio 15 with the same video card. I'm waiting for several months for any support for this card but the problem is you will only get a resolution of 1024x768 since it only boots in save mode.


Try booting with -x in the chameleon bootloader, this will get you trough the grey screen at the end of boot.

(-x stands for save mode and -v is verbose mode)


For more information on this video card see this topic



Lose the hope you will get this working soon, nobody has

Link to comment
Share on other sites


  • Create New...