Jump to content
oldnapalm

Still waiting for root device

12 posts in this topic

Recommended Posts

Se o boot no modo verbose parar nesta mensagem, é provável que você não tenha instalado o driver correto da controladora SATA/ATA. Estes drivers também são chamados de chipset drivers, e os mais comuns são Intel (AppleIntelPIIXATA.kext), VIA (AppleVIAATA.kext), ATI (AppleATIATA.kext) e nForce (AppleNForceATA.kext). Consulte o manual da sua placa mãe ou o site do fabricante, descubra qual a controladora onde o seu HD está ligado e instale o driver correspondente.

 

Se a sua controladora possui a opção AHCI na BIOS, utilize esta opção que ela deve funcionar sem drivers adicionais.

 

Veja aqui como editar a kext original para que a controladora Intel funcione no modo IDE.

 

Veja aqui como configurar o Windows Vista ou 7 para funcionar no modo AHCI, caso você tenha instalado com a controladora no modo IDE.

Share this post


Link to post
Share on other sites
Advertisement
Se o boot no modo verbose parar nesta mensagem, é provável que você não tenha instalado o driver correto da controladora SATA/ATA...

 

Depois de toneladas de testes e tutoriais(e 2 meses tentando passar disso), a unica coisa que resolveu meu problema com o Still waiting for root device foi: COLOCAR O DVD no SATA ZERO(a 1ª porta que você tiver) e os HDs depois do DVD(SATA 1,2,3,4...), foi na hora... :) nunca mais deu esse problema, desde que esteja configurado na BIOS pra AHCI ou RAID

Share this post


Link to post
Share on other sites

Qual a sua placa mãe?

 

Provavelmente seja uma particularidade do seu hardware. Normalmente funciona independente da porta SATA, mas já ouvi falar de casos parecidos com o seu.

Share this post


Link to post
Share on other sites
Se o boot no modo verbose parar nesta mensagem, é provável que você não tenha instalado o driver correto da controladora SATA/ATA. Estes drivers também são chamados de chipset drivers, e os mais comuns são Intel (AppleIntelPIIXATA.kext), VIA (AppleVIAATA.kext), ATI (AppleATIATA.kext) e nForce (AppleNForceATA.kext). Consulte o manual da sua placa mãe ou o site do fabricante, descubra qual a controladora onde o seu HD está ligado e instale o driver correspondente.

 

Se a sua controladora possui a opção AHCI na BIOS, utilize esta opção que ela deve funcionar sem drivers adicionais.

 

Veja aqui como editar a kext original para que a controladora Intel funcione no modo IDE.

 

Veja aqui como configurar o Windows Vista ou 7 para funcionar no modo AHCI, caso você tenha instalado com a controladora no modo IDE.

 

É a segunda vez que isso acontece comigo e não consegui mais dar boot ( isso depois de já estar funcionando bem há algumas semanas) mas dessa vez percebi que logo após eu instalar o mac drive no xp e salvar um arquivo no hd do mac aconteceu isso!! será que tem relação??

Share this post


Link to post
Share on other sites

A minha tela era exatamente a mesma que a sua e só consegui passar disso colocando o DVD como SATA ZERO(ou seja, na primeira porta que tiver na sua controladora) e o HD logo na porta seguinte, detalhe que demorei semanas pra descobrir tambem é que depois de formatar a primeira vez já pela instalação do MAC OS é que se der problema e nao terminar a instalação na primeira vez, cada vez que você for "formatando" ele não vai simplesmente apagando e começando do zero... (aqui só deu pau isso) tive que entrar no windows e procurar como remover a formatação do mac pela linha de comendo do windows e ai sim dava pra fazer novas tentativas e inclusive formatar de novo pelo instalador do MAC os... mais comece verificando se seu DVD esta antes do HD nas portas e se ele esta logo na primeira porta que pra mim funcionou sim

 

boa sorte

 

Pra mim tmb. comecei ontem a tentar instalar o snow leopard mas ainda não sai disso

tenho uma p6x58d-e core i7 950, 12 Gb. 1333, HD Segate 500Gb.

 

Se alguém puder dar uma dica agradeço.

 

 

 

http://imageshack.us/photo/my-images/707/52271130.jpg/

Share this post


Link to post
Share on other sites

Um amigo me disse agora a pouco que com esse comando o problema e resolvido

idlehalt=0 -v -f -x32

 

Eu nao testei para ver se funciona, mas se alguem precisar esta ai a dica

 

boa sorte :D

Share this post


Link to post
Share on other sites
Um amigo me disse agora a pouco que com esse comando o problema e resolvido

idlehalt=0 -v -f -x32

 

Eu nao testei para ver se funciona, mas se alguem precisar esta ai a dica

 

boa sorte ;)

 

ae galera, tentei esse seu comando ai e nada, mesmo coisa =/

 

seguinte, baixei os drive para mac no site da msi, e agora como eu faço para instalar eles a partir do windows 7?

 

vlw

Share this post


Link to post
Share on other sites

Esse comando sozinho não resolve, você tem que instalar a kext ATA.

 

Use o TransMac e coloque a kext em /System/Library/Extensions, depois faça boot com -f -v.

Share this post


Link to post
Share on other sites

Ola,aqui to tendo esse problema com o lion 10.7.2 depois de tudo instalado e na bios ta enchange S-ATA,não conssigo bootar em -v -f e nem -v -x para em "still waiting for root device" em -v boota de boa,vai saber :wallbash:

Share this post


Link to post
Share on other sites

Opa Old vou tentar aqui,vlw

Editado:Old não funcionou e eu tava atras do auto-sleep tambem resolvi instalar tudo do zero e agora não estou mais usando o UseKernelCache no boot.plist to tudo funcinando 100%.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×