Jump to content

Snow Leopard 10.6.3 on Qosmio Toshiba X300

5 posts in this topic

Recommended Posts



Qosmio Toshiba X300 install with iATKOS S3 version 2 :

found : iATKOS S3 - Snow Leopard 10.6.3 Hackintosh

Works fine with (choose during install personnalisation of OSX):

Chameleon V2 RC5 Pre8

RTC32 (32bits)

and don't install audio drivers




before : After install, try this audio driver :



remove "read only" in informations file VoodooHDA.kext and after


1.extract the zip to your desktop (not into a folder, literally to your desktop) this means there should be a file on your desktop called VoodooHDA.kext


2. open Terminal, (/applications/utilities/terminal.app)


3. type sudo -s in terminal then your admin password following this, now you should be root.


4. type sudo mv /users/(YOUR USERNAME)/desktop/VoodooHDA.kext /system/library/extensions

at this point the file VoodooHDA.kext should have dissapeared from the desktop,


5. type sudo chmod -R 755 /System/Library/Extensions/VoodooHDA.kext


6. type sudo chown -R root:wheel /System/Library/Extensions/VoodooHDA.kext


7. now, CLOSE TERMINAL (if you want you can put file VoodooHDA.kext "read only" on the new directory)


10/10/2010 : Last version of multiBootloader Chameleon 2RC5 r361:



known problem after a two day test


1) micro and audio out together (remove input sound in control panel)


2) keyboard/pad->external keyboard and mouse



Specification Qosmio X300-160 (PQX32E)

Motherboard chipset

Intel PM45


Processor speed

Intel Core 2 Quad Q9000


Amt of RAM

4096 MB (max 8192 MB)

Hard drive

500 GB (Extended Journaled formatting + XP SP2 and Seven64bits)

Optical drive

DVD writer


eSATA/USB2.0; VGA out; HDMI out

Bluetooth Yes Infrared Yes Ethernet 10/100/1000 Modem 56K data/fax Webcam

BIOS version 2.1 (14/04/09)

Built-in devices

ExpressCard slot

Wireless LAN 802.11a, 802.11b, 802.11g, 802.11n

Graphics hardware

Nvidia GeForce 9700M GTS

Carte audio

Realtek ALC272 @ Intel 82801IB ICH9 - High Definition Audio Controller

Amt of video RAM


Link to comment
Share on other sites

  • 1 month later...
  • 1 month later...
  • 2 weeks later...

I have a laptop from the same series, namely X300-15T. I too am having strange issues, even more strange is that after setup, the sound worked fine, unlike the others in this thread. I used the IATKOS s3v2 installer like you said, and it seems to install successfully, but when I reboot, the welcome music will start but the keyboard and mouse won't work and a message says "please plug the keyboard in". As I have no external keyboard to hand, I'm going to try the 'SnowOSXUniflash' installer instead, and report back. Thanks for posting about your qosmio laptops, as you say it is hard to find others trying to get OSX running on this laptop! Maybe we can work together to get bluetooth and wifi working, as I know those will be issues when I do get OSX going. Ironically, when I run "system profiler" from the setup, it says I have a 'macbook pro 4'...

Link to comment
Share on other sites

  • 1 month later...

Just a follow-up: I have not yet fixed the sound problem, but I've managed to get wireless to work. There is NO OSX kext driver for the Intel AGN card the laptop comes with. Many people who have this card with their laptops have this problem, but after 2 years there still is no driver for OSX for it. I therefore bought a supported Broadcom Airport N card from eBay, but then found a new problem: because the card was not designed for the laptop, there is a bogus OFF command being sent to it!

Because of this, even though the card was recognised in both OSX and Windows 7, it could not detect any wireless networks as the radio was forced to be OFF. This is despite the switch on the front of the laptop being set to ON.

Apparently this is a common problem with laptops that have a physical on-off switch for the wireless when using third party cards. After digging around other forums I found that you need to cover pin-20 on the card with a piece of sellotape to force it to ignore the bogus "OFF" command. And wow, this means wireless now works in both Windows and OSX! One word of warning: you WILL discover that this laptop has a second slot apparently to have two cards in at once, but the second slot would NOT recognise any card I put in it. Therefore, do NOT waste your time trying!



As for graphics, I got hold of a separate Chameleon installer and enabled 'injection' to get my Nvidia card to work.

All in all, a nearly perfect OSX install with wireless and proper graphics! Only fixes left to find are the sound problem above, and sleep support (trying to put it to sleep freezes it). I've successfully updated to OSX 10.6.5 (latest) with no issues, and am very happy so far. Hope this helps/inspires anyone with a similar laptop...

Link to comment
Share on other sites


  • Create New...