Jump to content

SOLVED! Native resolution on intel gma 4500 MHD - Vaio vgn-fw351j


5 posts in this topic

Recommended Posts

SOLVED!!! Roll down to post reply!


Hi guys,


My first topic here.


I have been reading a lot about possible hardware installations on my vaio and so far I have only managed to get the ethernet driver working correctly.


I am running iDeneb version 1.4 (Leopard 10.5.6) on 1024x768 resolution.


My onboard audio driver is not working but that`s not a problem since I use an external audio card (USB)

My ethernet is working with the IO Networking Family kext mentioned here.

My wireless is not working, but apparently there is no available driver just yet.

No problems on USB, blu-ray/dvd drive, keyboard or touchpad drivers.


But my main concern is my video driver, so I can get native resolution, and not get stuck on 1024x768.

It is an Intel GMA 4500 MHD Graphics onboard video card.


I have tried suggestions from other topics, but none seem to work.


Any ideas?

Thanks! =D



My config:


Sony Vaio VGN-FW351j


Intel® Core™2 Duo Processor T6400 2Ghz


320Gb Serial ATA

Blu-ray Disc™ Drive (reader/writer): BD-R/-RE/-ROM/ DVD+-RW/+-R DL/RAM Drive

X-black LCD with multiple lamp with FULL HD

Intel GMA 4500 MHD Graphics

Intel® WiFi Link 5100 AGN

Marvell Yukon 88E8055 PCI-E Gigabit Ethernet Controller

Link to comment
Share on other sites

Hi guys,


I am writing this topic because many people can't seem to figure out how to get native resolution on Intel GMA 4500 cards simply because the information is segregated.


Here it goes...


I have managed to get native resolution on my 4500 MHD video card by using the Chameleon 2 RC4 bootloader and editing the com.apple.boot.plist as mentioned in THIS SITE.


First of all you need to install the bootloader.


How to Install Chameleon Bootloader: (thank you taranfx!)

Assuming your Root disk is /dev/disk0s1

(This means: ASSUMING YOUR OSX86 IS ON THE FIRST PARTITION OF THE FIRST HDD! If it is on the second partition of the first HDD, you should put rdisk0s2, on the third rdisk0s3, and so on. On the second HDD, rdisk1s0, etc.)


Step 1. Gain Root priveledges and navigate to Chameleon Directory


Open terminal and type:

sudo -s

cd Desktop/Chameleon-2.0-RC4-r684-bin/i386


Step 2. Install boot0 to the MBR:


sudo fdisk -f boot0 -u -y /dev/rdisk0


Step 3. Install boot1h to the partition’s bootsector:


sudo dd if=boot1h of=/dev/rdisk0s1


Step 4. Install boot to the partition’s root directory:


sudo cp boot /


And that's it!


Now let's go edit the com.apple.boot.plist file!


If you boot in Single User mode you are root so you can type

nano /Library/Preferences/SystemConfiguration/com.apple.Boot.plist


If you booted in GUI run Terminal and type

sudo su

type your password

type the command same command line as in single user mode.


edit the file by adding...


<key>Graphics Mode</key>


(You may edit these settings according to your native resolution: 1280x1024x32, 1290x720x32, etc.)


to the text body of the file.

type Command-X to save and exit.


Don’t forget to check for the existance of com.apple.Boot.plist both in /Extra and /Library/Preferences/SystemConfiguration directories.


Reboot and good luck!


Anyway, i still can't run onboard audio, wireless and webcam.


Now I am trying to get my Alesis Multimix USB 2.0 to work with protools HD with the "team XVX" hardware emulator version, but with no success. The hardware is not recognised by the driver.


I guess the solution is either go back to using Logic or a digidesign/m-audio interface.


Thanks again!

Greetings from Brasil :)

Link to comment
Share on other sites

  • 2 months later...
  • 2 weeks later...
  • 7 months later...

  • Create New...