Jump to content

VirginMobile Broadband2Go USB mobile 3G card MC760 on Hackintosh?


1 post in this topic

Recommended Posts

VirginMobile recently had some mobile broadband deals and I jumped on it and puchased their USB mobile broadband modem MC760 by NovaWireless.


It installed and worked fine with my MacBook Pro (Early 2008) but didn't install correctly with my Dell Mini 10v hackintosh. During the last step of the installation, the firmware bundled Driver (Broadband2Go.mpkg) installs a Dialer app and 2 kexts into the /System/Library/Extensions/ and /Libriaries. It took more than 5 minutes to complete (while on the MBP, it only took less than 2 minutes.)


And then it requires an immediate restart, which took forever to complete as well. After rebooting, the Broadband2Go dialer app has this forbidden sign image overlaying the icon, and it prompted: "the app cannot be run because it's corrupted or incomplete". I also noticed that the kext permissions were way off then fixed them using Disk Utility, still no go after the permissions repaired.


I wonder if anyone has any luck to get that particular USB Mobile 3G card to work on hackintosh? And what's culprit?

Link to comment
Share on other sites


  • Create New...