Jump to content

Canon MP610 seen as scanner only in OSX - Help!

7 posts in this topic

Recommended Posts

Hi guys!


So after an hour on the phone with Canon and getting nowhere, I'm posting here (maybe I should have just done that in the first place). I have a Canon MP610 printer/scanner/copier. I am running OSX 10.6.4 on my newly built Hackintosh (i'll put specs below). For some reason, OSX only sees my printer as a scanner when I go to "Print & Fax" in System preferences. I have no idea how to fix this, I'll list what I've already tried. I've tried all the drivers for my printer on Canon's website (including the 10.5 ones), I've tried repairing disk permissions, I've tried setting up a second admin profile and seeing if it would see it there, I've tried booting in safe mode to see if it shows up. System Profiler sees it just fine, so it's something between the drivers and the printer. The printer works fine when I boot into Windows 7. Can anyone help? Let me know if you need something posted from my system specs.






i7 920 2.66 Ghz (overclocked)

6GB OCZ RAM @ 1600

EVGA GTX 295 CO-OP edition

EVGA e758 Motherboard

Link to comment
Share on other sites

I don't have an answer for you, but I can tell you that I have it working fine in 10.4.11 on my Powerbook G4.


It's a real bitchy printer though. Are you able to try the Tiger drivers from Canon's website?


It works fine on a regular Mac, just not my hackintosh (I have a Mac Pro I'm replacing with this, well hopefully, I don't really want a computer that can't use a printer). I was running Snow Leopard on the Pro, I should have copied the drivers over, but stupid me figured it'd be better to go with a clean install.


These are the listed drivers/software:


ICA Driver Ver. 1.3.0m (Mac OS X 10.6)



5.37 MB



MP610 series CUPS Printer Driver Ver. (Mac OS X 10.5/10.6)


9.51 MB



MP610 series Scanner Driver Ver. 13.9.1 (Mac OS X 10.2/10.3/10.4/10.5/10.6)



7.07 MB



MP610 series Printer Driver Ver. 6.9.3 (Mac OS X 10.2/10.3/10.4/10.5)



6.22 MB



So Tiger drivers are the same as Leopard, unless there's a place in the package where I can extract them and install them manually instead of using the installer?


Actually I just had an idea. I'll try reinstalling OSX on my Mac Pro, then if I can get it to work, I'll just copy the preferences and printer folders over to the hackintosh.

Link to comment
Share on other sites

I had the similar problem with my MP500. I then removed my IOUSBFamily and changed IOUSBFamily-378.kext and it works. Google for it, and try it out. Good luck.


Thanks I'll give it a try, my copying settings over from my old computer didn't work.

Link to comment
Share on other sites


  • Create New...