Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Shunnabunich

NOLF2 in Snow Leopard - Audio Problems?

3 posts in this topic

Recommended Posts

I suppose it's possible I'm the only person alive who: (1) still plays the excellent No One Lives Forever 2 from time to time, (2) uses the Mac version instead of the Windows version, and (3) does it on a Hackintosh. :thanks_speechbubble: Nevertheless, I figure I should at least try, eh?

 

I've played it on Leopard, and even after the crazy stretched-polygons issue was resolved through OS updates, the framerate is unplayably sluggish — even though I'm on a 1GB GeForce 9500 GT. So clearly, something else is preferable...it worked well way back on Tiger, but I'm not going through that headache on my Hackintosh.

 

I'm booted into SL (10.6.4) at the moment, and have tried playing it. The framerate is, to my delight, smooth like buttah. There's one big fat caveat, though: there's no sound. As in, it doesn't even load. Characters don't even bother moving their mouths. For a spy game that often forces you to rely on hearing approaching footsteps for survival, that's less than awesome.

 

I've checked the game's log file, and after reams of OpenGL stuff, it includes the following:

2010-06-25 19:39:55.767 NOLF2[167:207] Looking for bundle at '/Games/No One Lives Forever 2/NOLF2.app/Contents/Resources/SndDrv.dll'
2010-06-25 19:39:55.771 NOLF2[167:207] Looking for bundle at '/Games/No One Lives Forever 2/NOLF2.app/Contents/Resources/SndDrv.dll'
Unable to create OSMixerAudioUnit!
MessageBox(ILTSoundSys error ...): Failed to initialize sound driver 'SndDrv.dll'.
Execution may terminate...
glob: No such file or directory
2010-06-25 19:39:55.801 NOLF2[167:207] -[OSDefaultOutputAudioUnit init]: OpenDefaultAudioOutput -> -4
Convert32to32
OutputDebugString: Game initialized in 18.132999 seconds.

OutputDebugString: LithTech build 4294967295.4294967295 initialized in 20.64 seconds.

NewMovieFromFile --> -2048
NewMovieFromFile --> -2048
2010-06-25 19:39:56.885 NOLF2[167:207] -[OSDefaultOutputAudioUnit init]: OpenDefaultAudioOutput -> -4
2010-06-25 19:39:56.908 NOLF2[167:207] Load: Don't understand track with CLSID 'CLSID_DirectMusicSeqTrack'
2010-06-25 19:39:56.985 NOLF2[167:207] -[OSDefaultOutputAudioUnit init]: OpenDefaultAudioOutput -> -4
2010-06-25 19:39:56.987 NOLF2[167:207] -[OSDefaultOutputAudioUnit init]: OpenDefaultAudioOutput -> -4
2010-06-25 19:39:56.990 NOLF2[167:207] -[OSDefaultOutputAudioUnit init]: OpenDefaultAudioOutput -> -4

 

If I had to take a wild guess, I'd say that perhaps either SL or my VoodooHDA driver has introduced some compatibility problem with NOLF2's sound driver, preventing it from loading or playing anything? Obviously, I'm not going to find official support for such an old game, and I thought I'd try here first before one of the more mainstream Mac forums, on the off chance that it's a Hackintosh-specific thing.

 

Anyone else experience this problem? Anyone found a fix for it, or understand what's going on? Thanks and optional bro-hugs in advance!

Share this post


Link to post
Share on other sites

Hey there,

 

I´m experiencing the same problem on a MacBook Pro... Mac OS X 10.6.5

Have you found any solution yet?

 

Thanks for any advice

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×