Jump to content

Still waiting for root device FIX!

2 posts in this topic

Recommended Posts

I wanted to write a complete tutorial on how to install IPC OS X on my current hardware however after encountering this daunting error i decided once i had fixed it i would share my experience in fixing it, as i would think that would be much more valuable to the community.


I started my attempt to install by formating a partition and doing the usual process of formating the partition to hfs+ through windows diskpart. After that i restarted my computer and attempted to install only to be left with the error "still waiting for root device"


I was positive it was a bios setting i had over looked though against my better judgement i downloaded 4 different OSX86 distros in attempting to bypass this issue each with the same result *Distro's i tried : Kalyway 10.5.2, Jas 10.4.8, IPC 10.5.6 and ideneb 10.5.7*


The simple fix was entirely a bios related problem. When loading the waiting for root device is completely a hard drive related problem as i will later detail.


In bios i had set ahci for my hard drive with sata ports 4 and 5 set to ide mode. This did nothing alone to fix the problem. So i turned to plugging my hard drive and dvd rom into the 4 and 5 port thinking if they are recognized as ide they might be picked up, however this did not work because i had accidently unplugged my sata hard drive and left only my dvd rom plugged in. As i realized that 4 and 5 did nothing i decided to leave bios settings the same and try ports 2 and 3 which stay set as sata recognized, when i did this i left the hard drive unplugged and moved my firewire sata plug and my dvd rom to 2 and 3 thinking the firewire was the hard drive.


To my surprise the install dvd shot out some of the same errors about unloading across sleep or something of that nature but instead of the dvd rom not doing a thing it kicked in and started flashing. The install eventually led me to the disk utility which i then released i had no hard drive.


I plugged the hard drive back in and tried every config in every plug i could with absolutely no success! Eventually i got to where both where plugged in the 2 and 3 spots on the sata plugs and both where going into ahci mode however once both where in ahci mode i was getting the error *No bootmgr* which i then realized after setting the mac partition as active and getting a bootmgr error, that it was trying to boot into the hard drive and not my dvd rom. This lead me to the bios where for what ever reason once switching to ahci mode my dvd rom was not selected in the first boot sequence but rather cd rom *which i did not have*. After viewing the selections i saw that instead of giving a general boot item like *dvd rom, cd rom, harddisk or usbhdd* i had one item that was specific and named the exact model of my dvd rom. None the less i selected that dvd drive as first boot sequence and fired it up. Voila no more still waiting for root device.



Simple answer is set ahci mode in bios, make sure your devices *dvd rom running disk and hard drive you plan to install on* are on sata ports that are not dedicated to ide *or simply turn the ide setting to sata* then reselect your dvd rom in bios boot sequence if you happen to get the bootmgr error on start up. This should fix anyone's *still waiting for root device* error short of your hard drive either not being partitioned properly and set to active or your hard drive just dying and theres no fixing it.

Link to comment
Share on other sites

  • 6 months later...

  • Create New...