Jump to content

How to run BCM4328 14e4:4328 BCM94321 iatkos s3 or retail


1 post in this topic

Recommended Posts

Hello members,


first of all i want to give you a big THANKS for all of your posts which helps me to run mac Snow Leo on my x86!!!


Now i need help to install my broadcom bcm4328 14e4:4328 BCM94321 (mini PCI express) on iatkos s3 v2 or retail installation. The card is a original by Apple. See Attatchment. BCM94321MC.jpg



Ive already tried to get this card running on iatkos s3 v2, a retail installation of snow leopard 10.6 and additional update to 10.6.3 but nothing works.


I get in all distros the same error:


- In System Profiler listed as 14e4:4328 Broadcom Error: Unknown device

- In Network Utility is the card missing... It only shows a realtek lan card and firewire card which are actually not plugged in..


- I dont have the possibilty to enable / disable a wifi card in my bios

- Card works perfectly in Windows Vista



So can someone help me with this issue?

I dont have a clue to solve my problem...


My System:

Fujitsu Siemens Amilo Pi 1556 Notebook

Intel® Core™ 2 Duo processor with ICH7 Chip

T5500 (1.66GHz, 667 MHz, 2MB L2 cache)

2,5GB DDR2 533MHz

1x SATA HDD (5400rpm): 120GB

PCI Express graphic card based on MXM Type 2:

nVidia Geforce GO 7600 with 256 MB DDR2 dedicated Video RAM


Thanks in advance



Link to comment
Share on other sites


  • Create New...