Jump to content

Couldn't copy necassary support files

7 posts in this topic

Recommended Posts

Hello Everyone,


I am new to the osx86 project. I decided i would try and install snow leopard on my pc. I followed a guide on the osx86 wiki, which said to use [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] to get into the dvd, and from there i could install. So i went into my bios, loaded the optimized defaults, and booted from the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] supported cd. Then I switched to my Snow Leopard DVD and began booting. I formatted my hard drive to a guid partition table, and to a mac os extended (journaled) format. I began the install. The status bar gets to around 35%, and then it displays the following error:


"Installer couldn't copy necassary suport files." and there is a button to reboot.


I have tried the nvidia [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] cd, and it didnt work. I tried messing with my bios, didnt work. I tried messing with the install options, didnt work. 


Any help would be appreciated. So far it seems hopeless :)

Link to comment
Share on other sites

Hello everyone,

I tried the hackboot method and os x is now installed and running on this pc. :D

I am encountering several problems though...

I MUST boot from the hackboot cd. I installed cameleon and tried to boot from that, but i get the apple logo with the x through it.

Also, i can only have my screen resolution on 1024x768 instead of 1280x1024. My Lan doesnt work (onboard or pci) and neither does my sound.

Also, about this mac seems to get the hackintosh to run a "killall Dock".


If anyone can help me with any of these problems, please do :P


BTW, my specs are:


Foxconn P9657aa-8ks2h motherboard

Intel core 2 duo 2.33 ghz

2gb ocz ram

nvidia 7600gt

realtek onboard sound

d-link dfe-530tx LAN

lite-on dvd rom drive

WD 60gb ide hard drive (will swap out for a better one, after i am done testing my hackintosh)


Posted from an imac g3 :P

Link to comment
Share on other sites

you installed these two files?

"Chameleon-2.0-RC4-r684.pkg" (by OldNapalm)

"Install Extra"


after installing these two files, go in HackBoot (folder sata/ata)

and copy the necessary kext(sata/ata)


try voodoohda.kext (audio)


first you must get rid of bootcd


After fine-tuning

Link to comment
Share on other sites

you need drivers Data/Ata


use the-x and see if the error is still waiting ...


go on hackboot, folder "KEXTs/SATA-ATA"





*has kexts that do not work on efi

Link to comment
Share on other sites


  • Create New...