Jump to content

Edimax USB adapter (EW-7711UAn) SOLVED


4 posts in this topic

Recommended Posts

Hi guys, i could use some help :D


Yesterday i bought my Edimax 150Mbps Wireless 802.11b/g/n High Gain USB Adapter (EW-7711UAn) which support any version of Windows, Mac (from 1.4 and above) and Linux. Within the package i bought, was the USB adapter, a crappy "guide" as they call it, and an installation disk, but the disk don't bring up the installation wizard in Mac...


I got Kalyway_10.5.2_DVD_Intel_Amd.


When i plugged in the USB adapter it didn't do anything, same as with the disk ;( I opened the disk and found a folder called "Mac Driver" and found a *.dmg file with the driver for 10.3, 10.4 and a 10.5 folder, which contained an install and an uninstall file for the driver.


When it's finished installing, it asks me to reboot, and i do that. But when my computer are done, it just seems like nothing happened... No wireless icon thingy, nothing at the network pane under System Preferences... I tried downloading another *.dmg file from the Internet with the same files within, after the install, i found an application called "USBWirelessUtility" but the app can't find my adapter.. ;( The weird thing is, that the System Profiler can find the USB adapter..


802.11 n WLAN:


Version: 1.01


Bus Power (mA): 500


Speed: Up to 480 Mb/sec


Manufacturer: Ralink


Product ID: 0x7711


Serial Number: 1.0


Vendor ID: 0x7392



The installation file tells me that i gotta go open the network pane under System Preferences and configure it, but nothings there....



Pleeeeeeeeeeeeaaaaaaaasssseee... It's the only thing i need for my computer to be complete ;P Anyone got a solution? ;D ;D






Link to comment
Share on other sites

I got my Edimax to work with snow leopard.


I got this email from customer support:


Did you use the EW-7717Un Mac driver from our USA site at [url="http://www.edimax.us"-> download section?


In the "Site survey" tab of Wireless Utility software, there is one information text box located next to the "Rescan" button. What do you see in that information box? Does it say "Disconnected" or "No Device"?


Should it say "No Device", please try unplug the EW-7717In from your system and replug it back in.


Best Regards,

Judy Chang

Tech Support

Edimax Computer


Once you install the new driver (It is a different driver than on most of the forum here- but from the same site) plug in the edimax to a usb port. The application Ralink Wireless Utility will open up (I had no success with this earlier- but did work with this download). If it doesn't open find it in the applications folder and open the wireless utility. The instructions sent by edimax are even more confusing then the earlier useless insert that is sent with the unit. I did not have to download a certificate to get it to work. Go to site survey scan for your router (mine was airport express- it was labelled something else) Take note of the SSID, Authentication and Encription. Highlight the network you want to join hit add profile.


Under the tab of authentication & security Put in the authentication type and the Encryption type from the scan. Bcause I choose wpa- My wpa pre-shared key turned out to be the password I use to access my router. (pre-shared key = password???) Hit Ok . It should give you a green box with a checkmark under the profile tab. If not highlight the profile you want and hit activate.( I didnt have to do anything with my security preferences.


I hope this helps you. But it is entirely possible that in the forty five minutes before I could figure out the instructions I did something random and unrepeatable that made the edimax work. The good news is that it does work so keep playing with it.

Link to comment
Share on other sites


  • Create New...