Jump to content

Problem installing OS X native


5 posts in this topic

Recommended Posts

Hi Guys,


Please welcome a new member to this forum. :D


I have to admit I always used Windows but since I got a Mac G3 (slow one) and my collegue purchased an iBook I want to take a look at OS X because at first impression I liked it. For I don't have the budget now to buy a real mac so I would like to test it on my current pc and if I enjoy using it my next new computer will be a iMac! Since I have pretty compliant hardware (I think) it should work fine on my pc so I gave it (several :angel: ) tries. below more info


Computer specs


CPU: Intel Prescott 630, 2 MB Cache, SSE3 enabled, EMT64 & HTT enabled

Mobo: Intel 915 PBL, serial ATA matrix raid, one IDE channel

Memory: 2 GB RAM

Optical: PX-716 Serial ATA

Harddisk: 2 x 200 Gbyte S-ATA


I also have for testing purposes


1 x 20 Gb IDE



The Install discs I have:


10.4.6 HotISO release (which is the JaS patched one I saw on several posts)

10.4.3 patched, got it from a collegue so I don't know which exact release it is.



One month ago I did a quick try to install 10.4.3 on my pc but gave up since it didn't detect my S-ATA optical and drives. I didn't had test devices with me so I gave up. Now a month later I tried again and I want to get this working...


Install try one (try to get it working...)


I just connected my two test devices (PATA disk and optical) to my pc and disconnected all S-ATA devices. Then I used the 10.4.3 installer which was pretty slow but booted into installer. The P-ATA drive I got from my mac G3 and was already formatted with HFS journaled in the PowerPC installer. I erased the drive using disk utility and went on installing OS X


After installation I rebooted and got the message that no OS was found. I rebooted with installer and using startup utility I chose to reboot from harddisk, after that OS x just booted and ran fine: it even detected my NIC by example... The issue is: I always need to boot from the installer CD because direct booting from harddisk does not work...


I tried to find some information how to fix the direct-boot issue but couldn't get this fixed...


After my other test I'm thinking it could be one of those two:


a ) The x86 OSX hacked OS X disk does not support native booting

b ) Partition table issue? Partition not active or something else I'm not aware of?


So I gave up because I didn't found help via the Wiki's..



Then I wanted to try if I still didn't get my S-ATA drives working..


Install try two (my preference to get this working)



Disk Configuration


One month ago I already tried this but I got the message that the installer could not find the root device so I was thinking my S-ATA controller was not supported and after some switching drives I gave up... I forgot one thing, see below...


Some time later on I was thinking: OS X will never recognize the discs when I put them in Intel Matrix storage (raid) mode and that would be the issue. So I reconfigured my BIOS's S-ATA settings. I changed the mode from 'enhanced' to 'legacy' so it kind of emulates 2 IDE channels and mapped the 4 S-ATA channels to ATA locations. I configured and connected drives so they are recognized as


Pr Master: Harddisk

Secondary master: PX-716SA

Sec Master: harddisk


I booted the HotIso image and it was booting (and pretty fast!). It detected my optical and two harddisks so I think the S-ATA issue is thereby fixed. I got into the installer and used disk utility to remove existing partitions and create a new HFS extended journal partition. I installed Mac OS X and then the computer rebooted... I tried to boot from Harddisk and I only got b0 on my screen... I did some research and found that I should make the partition active, which I did using a Linux floppy. After that I got the message that Mac OS could not find '/Library/Preferences/SystemConfiguration/com.apple.Boot.plist'


This was yesterday night very very late...


I don't really have an idea what could be causing the issue but I'm thinking about the same two options as my previous attempt... This is why I opened this post...


Other questions


I also am wondering why I can't find 'native' guides, I only find dualboot guides, is this because

a ) it just does not work with the hacks?

b ) It should just work out of the box?



Then I just wanted to start creating a dualboot and wanted to follow the guides step by step so I booted Norton ghost to restore my disk image but suprisingly it did not found my harddisks... Is this because the OS X installer screwed partition table or has this nothing to do with it? Didn't have the time to check this out yet but maybe one of you could tell me t his in advance... Anyway it was 4 AM so I quit and went to sleep.



Conclusion: I'm stuck right now and I'm planning to continue sunday in the evening... Can somebody advice what I forgot/did wrong/still have to do...


For the moment I've got a OS X installed on my S-ATA disk which is giving the could not find '/Library/Preferences/SystemConfiguration/com.apple.Boot.plist' error. If this is easily fixable I - off course- would prefer this option.


many many many thanks in advance for the help!



Link to comment
Share on other sites

Hi Folks,


Just informing you guys that OS X is running fine and smooth now! :dev::D

The problem was my installation DVD for 10.4.6 (HotISO) which does not seem to work on my pc. I just installed 10.4.4 and everything is running great now :whistle:


Still one question: are there any guides available that explain how to update to 10.4.6 and 10.4.7... I just find some short explanations :angel:

Link to comment
Share on other sites


  • Create New...