Jump to content

No internet aftter 10.5.8 combo update?


6 posts in this topic

Recommended Posts

hi there,

I installed leopard 10.5.6 using the iPC OSx86 10.5.6 Universal PPF5 Final ISO, after a few attempts,a bad bios flash and finally a new bios chip I got it all installed.Everything was ok apart from NO internet,NO display resolution change and No sound.I read through the forums and tried lots of different kexts with no luck, apart from the internet which I sorted after (I think) using the Yukon88E8056.pkg , this then gave me internet.But after a few more days trying still no resolution increases on the display or sound.

So yesterday I decided to run apple update and update my system with the 10.5.8 combo update.

This ran ok and as long as I placed a DVI-VGA adapter in the first graphics cards second DVI connector I got 10.5.8 up and running already with 1600x1200 display and sound!

But...now I have no internet, in settings it says all 4 ports have ethernet unplugged?

Tried running the .pkg file again but no joy.

Thanks in advance if anyone has any ideas


CPU Intel Core 2 Quad Q9300 2.5GHz

RAM 2x2GB DDR2 800Mhz

GPU 2xRadeon HD 4850 not in crossfire (not sure if can run in xfire on mac?)



Onboard sound AD2000b

Ethernet Marvel yukon 88E8056 gigabit


Also reading through the forums theres alot regarding chmoding files to change permissions, is this done in terminal?

Link to comment
Share on other sites

But...now I have no internet, in settings it says all 4 ports have ethernet unplugged?

Tried running the .pkg file again but no joy.


try checking settings in bios


1) did you accidentally disable lan ports?

2) did you try loading bios defaults and resetting your bios preferences?

3) it may just be that your lan ports ARE working, you just havent properly applied settings in System-Preferences->Network

4) try kext i have attached

5) try inserting device quoted by Guedes Jr in the second post here http://www.insanelymac.com/forum/index.php?showtopic=73374

Link to comment
Share on other sites

sorry it didnt attach properly, but that kext i was intending to attach i just read didnt work for others in 10.5.8, so forget that idea. i found this fix for you searching around the forum...


you need to edit an ID in yukon.kext


your motherboard's LAN chipset is Marvell Yukon 88E8056 (or 88E8053 if have a certain revision but those chipsets shouldnt have problem you have, so I'm assuming your board has the 8056)




i would prefer to copy /System/Library/Extensions/IONetworkingFamily.kext to my desktop. then right click, show contents until you get to the Info.plist inside AppleYukon2.kext. Make changes, save and reinstall this edited IONetworkingFamily.kext with kext helper b7


here is the copied fix by Royco


Open the terminal from /Applications/Utilities and type the following:

sudo nano /System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns/AppleYukon2.kext/Contents/Info.plist

(find and change: <key>Yukon-88E8053</key>)
(to: <key>Yukon-88E8056</key>) <-- change "53" to "56"

(find and change: <string>0x436211AB</string>)
(to: <string>0x436411AB</string>) <-- change "62" to "64"

(find and change: <string>Yukon Gigabit Adapter 88E8053 Singleport Copper$</string>)
(to: <string>Yukon Gigabit Adapter 88E8056 Singleport Copper$</string>) <-- change "53" to "56"

Ctrl O <--- Thats letter O
Ctrl X

sudo chown -R root:wheel /System/Library/Extensions/IONetworkingFamily.kext
sudo rm -rf /System/Library/Extensions.mkext

After rebooting your LAN might not be working yet and showing up as disconnected. Do the following.
- Go to System Preferences, Click on the network icon.
- On the left pane select your ethernet, on the right pane where it says "Configure" select "off".
- Click apply.
- Now back to "Configure" select "Using DHCP". Click apply.
- Your LAN should be working by now.


threads i found on this are


here - http://www.insanelymac.com/forum/index.php...rt=#entry518777


and here - http://www.insanelymac.com/forum/index.php...rt=#entry245032

Link to comment
Share on other sites


  • Create New...