Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
-tanner-

Tiger won't boot using GRUB

2 posts in this topic

Recommended Posts

So, for a while i've had Windows Vista and Linux Mint 8 dual-booting on my computer. Vista had crashed a while ago and finally died (file system is shot to hell) a few days ago. When Vista died it also happened to take out Linux in the process. I've also had Mac OS X Tiger sitting nicely beside them, however I couldn't boot into it (the Vista bootloader couldn't boot it).

After Vista/Linux died I decided to re-install Linux and low and behold the bootloader found Mac OS X Tiger and added it to the list of bootable OS's (it didn't include Vista). However, when I try to boot Mac I instantly get a kernel panic ;) I've had Tiger working smoothly on this comp before too. Any ideas? (btw, the bootloader for Mac, Chameleon, doesn't recognize Linux)

 

My comp's specs are:

CPU - Intel Mobile Dual Core 1.46 ghz

GFX - Intel Mobile 965 Chipset

RAM - 1000 mb's (0.99gb lol)

HDD - 168 gb

 

Also, my drive is partitioned as such: (according to KDE Partition Manager)

 

/dev/sda1 - ntfs - Recovery - 7.37 GiB

/dev/sda2 - ntfs - Vista - 91.30 GiB

/dev/sda3 - Extended - 48.27 GiB

  • /dev/sda5 - hfsplus - Mac OS X Tiger - 19.99 GiB
  • /dev/sda6 - ext4 - Linux Mint 8 - 27.06 GiB
  • /dev/sda7 - linuxswap - Linux Swap - 1.21 GiB

unallocated - unknown - 2.11 GiB (used to be Linux Swap)

 

You may have noticed that sda3 isn't labelled and the next 3 partitions are under it. For whatever reason, sda5-7 are all connected to eachother. I didn't think you could that but I guess so lol.

I even uploaded a pic to help show what i mean lol.

 

The purple on the left is the Recovery, the pink in some of the partitions is used space. As you can see, sda5-7 are outlined in teal, connecting them together. Also, I've tried to extend sda6 to include the 2 gigs of unallocated space but it refuses to, because they are connected.

So yea, any help is appreciated! ^^

 

post-560173-1271625939_thumb.png

Share this post


Link to post
Share on other sites

You must have solved your problem so far but...

If you haven't solved it yet, first you must tell us which version of Grub you use and then show us the entry for Mac os x in menu.lst or grub.cfg (whichever you're using). That way, it'll be easier to help you.

 

If you're using grub legacy (that's if you have a /boot/grub/menu.lst file), the grub entry will simply be:

 

title Mac Os X

root (hd0,4)

savedefault

makeactive

chainloader +1

 

This entry should direct grub to darwin, I think.

 

grub2 is a bit complicated for me, but it should look like this:

 

menuentry

set root (hd0,5)

chainloader +1

 

In grub2, before attempting to edit grub.cfg manually, you can test if any change will provide success by highlighting mac os x and pressing "e" as soon as you see the grub screen when you start your computer. This way, you can change the boot parameters and immediately see the results.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.



×