Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
diogohack123

Hackintosh para HP Pavilion 2143 ez sem AHCI na Bios

29 posts in this topic

Recommended Posts

Meu PC hp pavilion 2143 ez nao tem opção de mudar para AHCI na Bios, alguem sabe como instalar sem mudar essa oppção na Bios??? Pq ja tive experiencia com hackintosh, ele nao da boot no hackintosh devido a não ter como mudar pra AHCI na Bios. Alguem tem o mesmo modelo ou ja ouviram falar disso- Obrigado

Share this post


Link to post
Share on other sites

Qual a controladora ATA? Se não tem modo AHCI, você vai precisar de uma IOATAFamily modificada com o device ID da sua controladora. Por exemplo, se for Intel, vai precisar adicionar o ID na AppleIntelPIIXATA.

Share this post


Link to post
Share on other sites

Já tentou instalar com o Snow Leopard 10.6.1-10.6.2 Intel AMD by Hazard ... ele já vem com alguns fixes bons tipo:

 

AHCIPortInjector

AppleACPIPS2Nub

AppleATIATA

AppleIntelGMA950 Fixed

AppleIntelGMAX3100FB Fixed

AppleIntelIntegratedFramebuffer Fixed

AppleIntelPIIXATA

ApplePS2Controller

ATAPortInjector

Share this post


Link to post
Share on other sites
Qual a controladora ATA? Se não tem modo AHCI, você vai precisar de uma IOATAFamily modificada com o device ID da sua controladora. Por exemplo, se for Intel, vai precisar adicionar o ID na AppleIntelPIIXATA.

 

 

 

Controladora da Intel mesmo! vou tentar esse kext IOATAFAMILY, VOU VER COMO MODIFICA-LA PQ NAO SEI, OBRIGADO MESMO!!

Share this post


Link to post
Share on other sites

Para começar você tem que descobrir qual o device ID da controladora.

 

Pelo Windows pode ver no gerenciador de dispositivos, nos detalhes aparece uma string que contém o ID nesse formato:

 

... VEN_8086 DEV_???? ...

 

Se você ainda não instalou, use a distro que o Ouverros recomendou, ela tem uma AppleIntelPIIXATA que já deve ter o ID da sua controladora.

 

Procure por "leohazard" no Google.

Share this post


Link to post
Share on other sites

Já tentou instalar com o Snow Leopard 10.6.1-10.6.2 Intel AMD by Hazard ... ele já vem com alguns fixes bons tipo:

 

AHCIPortInjector

AppleACPIPS2Nub

AppleATIATA

AppleIntelGMA950 Fixed

AppleIntelGMAX3100FB Fixed

AppleIntelIntegratedFramebuffer Fixed

AppleIntelPIIXATA

ApplePS2Controller

ATAPortInjector

[/quote

 

 

 

MUITO OBRIGADO, ACHO QUE VOU TENTAR ESSE SNOW, ME PARECE QUE VAI FUNCIONAR!!! OBRIGADAO!!!

Share this post


Link to post
Share on other sites
Já tentou instalar com o Snow Leopard 10.6.1-10.6.2 Intel AMD by Hazard ... ele já vem com alguns fixes bons tipo:

 

AHCIPortInjector

AppleACPIPS2Nub

AppleATIATA

AppleIntelGMA950 Fixed

AppleIntelGMAX3100FB Fixed

AppleIntelIntegratedFramebuffer Fixed

AppleIntelPIIXATA

ApplePS2Controller

ATAPortInjector

 

 

 

Bom pessoal, baixei essa versao do Leohazard, ta dando erro "efi inject get devprop string null stringdata" logo apos o fim do bootloader. Estou tentando outras configuracoes na customizacao, fora as que vcs ja me indicaram, mas ta dificil. alguem sabe sobre esse erro "efi inject" ?? Obrigado

Share this post


Link to post
Share on other sites

Esta mensagem não é bem um erro, acredito que tenha sido deixada por engano, ela aparece quando a opção GraphicsEnabler não está ativada, mas não impede o sistema de funcionar normalmente.

 

Faça o boot no modo verbose (-v) e veja onde está parando.

Share this post


Link to post
Share on other sites
Esta mensagem não é bem um erro, acredito que tenha sido deixada por engano, ela aparece quando a opção GraphicsEnabler não está ativada, mas não impede o sistema de funcionar normalmente.

 

Faça o boot no modo verbose (-v) e veja onde está parando.

 

 

Bom, é o seguinte: Com o DVD do Hazard fiz o boot em um Lenovo 3000 N200 para instalar o Snow em um Pen Drive de 16Gb, instalei e customizei com as dicas que vcs deram. Quando dou o boot pelo Pen Drive no Hp DV6 2143, apos o boot do chamelon ele da aquele erro de EFI INJECT.... que pelo que li e vc disse é da carta grafica (Nvidea GF GT 320 1GB)

Peguei o DVD do Hazard e dei boot no HP em modo verbose, ai ele vai até essa tela só, depois reinicia !!! Obrigado!

 

post-555610-1271113680_thumb.png

Share this post


Link to post
Share on other sites
Qual o CPU deste portátil?

 

Você tentou com "cpus=1 -v" no boot?

 

Se for Core i3/i5/i7 pode precisar "busratio=XX" no boot, aqui tem uma lista de CPUs e busratios

http://www.tonymacx86.com/viewtopic.php?f=3&t=642

 

 

Dessa vez funcionou a instalacao pelo DVD no HP DV6, fiz que vc disse( CPUS=1 BUSRATIO=17 -V , DE ACORDO COM A TABELA QUE ME PASSOU)) dai foi... mas... rsrs deu de novo o problema do EFI INJECT GET DEVPROP STRING NULL TRYING STRINGDATA.

Coloquei o PEN DRIVE no Lenovo 3000 N200, deu o erro efi inject tb, mas continuou a instalacao no carregamento onde tem a maca, depois deu panic, normal pq nao é o msm hardware.

Mas to pesquisando sobre o problema no HP, vi aqui no site em Italiano, mas ainda nenhum resultado. se tiver mais uma brilhante dica, pq essa do CPUS BUSRATIO foi otima, nao sei como vcs sabem tudo isso mas.... valeu, to no caminho... Obrigado

Share this post


Link to post
Share on other sites
Dessa vez funcionou a instalacao pelo DVD no HP DV6, fiz que vc disse( CPUS=1 BUSRATIO=17 -V , DE ACORDO COM A TABELA QUE ME PASSOU)) dai foi... mas... rsrs deu de novo o problema do EFI INJECT GET DEVPROP STRING NULL TRYING STRINGDATA.

Coloquei o PEN DRIVE no Lenovo 3000 N200, deu o erro efi inject tb, mas continuou a instalacao no carregamento onde tem a maca, depois deu panic, normal pq nao é o msm hardware.

Mas to pesquisando sobre o problema no HP, vi aqui no site em Italiano, mas ainda nenhum resultado. se tiver mais uma brilhante dica, pq essa do CPUS BUSRATIO foi otima, nao sei como vcs sabem tudo isso mas.... valeu, to no caminho... Obrigado

 

Seguinte: coloquei o PEN DRIVE no Lenovo onde tenho Ideneb funcionando, adicionei as "KEY" GRAPHICS MODE, GRAPHICS ENABLER e FORCEWAKE, com respectivas STRINGS, parou o erro da EFI Inject, agora aparece :

HIBERNATE IMAGE IS TOO OLD BY 2464 SECONDS.USE FORCEWAKE=Y TO OVERRIDE. E ele reinicia ainda.

 

Vou continuar tentando.....

Share this post


Link to post
Share on other sites

Como eu disse antes, a mensagem sobre o "efi inject" não é um erro, ela aparece sempre que o GraphicsEnabler não está ativado, deve ter sido deixada por engano.

 

Sobre o forcewake, se você usa o hibernatemode 3 (rode pmset -g no terminal para verificar) o Mac salva o conteúdo da memória RAM para o arquivo /var/vm/sleepimage (definido em hibernatefile). Se é encontrado este arquivo no boot ele tenta carregar, mas o Chameleon sempre diz que o arquivo é muito antigo, não carrega nem com forcewake.

 

Eu sempre desligo esta opção e removo o arquivo sleepimage que ocupa o tamanho da memória RAM no HD. Para desativar use o comando

sudo pmset -a hibernatemode 0

então pode excluir o arquivo /var/vm/sleepimage e não verá mais a mensagem no boot.

Share this post


Link to post
Share on other sites
Como eu disse antes, a mensagem sobre o "efi inject" não é um erro, ela aparece sempre que o GraphicsEnabler não está ativado, deve ter sido deixada por engano.

 

Sobre o forcewake, se você usa o hibernatemode 3 (rode pmset -g no terminal para verificar) o Mac salva o conteúdo da memória RAM para o arquivo /var/vm/sleepimage (definido em hibernatefile). Se é encontrado este arquivo no boot ele tenta carregar, mas o Chameleon sempre diz que o arquivo é muito antigo, não carrega nem com forcewake.

 

Eu sempre desligo esta opção e removo o arquivo sleepimage que ocupa o tamanho da memória RAM no HD. Para desativar use o comando

sudo pmset -a hibernatemode 0

então pode excluir o arquivo /var/vm/sleepimage e não verá mais a mensagem no boot.

 

 

Poxa, infelizmente nao ta dando certo! Ja tentei varias customizacoes possiveis...., todas reinicia apos boot.. O que sera?? Valeu...

Share this post


Link to post
Share on other sites
O Lenovo funciona perfeito o Ideneb, o problema é o HP !! Nada ainda....

Não estou entendendo, antes você disse que tinha funcionado.

 

Dessa vez funcionou a instalacao pelo DVD no HP DV6, fiz que vc disse( CPUS=1 BUSRATIO=17 -V , DE ACORDO COM A TABELA QUE ME PASSOU)

Share this post


Link to post
Share on other sites
Não estou entendendo, antes você disse que tinha funcionado.

 

Antes quando disse quando disse que funcionou, foi o boot do DVD para instalar o SNOW HAZARD no HP, instala certinho, mas quando é pra entrar no systema pra ter o video de entrada do mac,configurar nome de usuario, wifi... é ai que ele reinicia dp do boot do chamelon. A instalacao a partir do DVD funciona, mas apos para a configuracao ele reinicia, por isso que disse que ja tentei varias customizacoes com o DVD, mas ainda reinicia, nao sei o que pode ser... Obrigado.

Share this post


Link to post
Share on other sites
Mas você está digitando o busratio também ao fazer o boot do HD?

 

Está selecionando um kernel legacy na instalação?

 

 

Nao da pra eu dar o boot com CPUS E BUSRATIO no boot pelo HD pq ele vai direto pro boot do chamelon e nao tem opçao pra dar boot com os parametros.

 

Ja tentei Kernel Legacy e Intel.. e nada.

 

Com certeza è minha placa de Video Nvidea GT230 1GB, coloquei o HD com Ideneb Instalado e parou nessa tela.post-555610-1271839405_thumb.jpg

Share this post


Link to post
Share on other sites
Nao da pra eu dar o boot com CPUS E BUSRATIO no boot pelo HD pq ele vai direto pro boot do chamelon e nao tem opçao pra dar boot com os parametros.

É só digitar os parâmetros na tela do Chameleon, o que você digita aparece no canto inferior esquerdo da tela.

 

Ja tentei Kernel Legacy e Intel.. e nada.

 

Com certeza è minha placa de Video Nvidea GT230 1GB, coloquei o HD com Ideneb Instalado e parou nessa tela.

O kernel panic dessa tela é por causa da VoodooHDA (driver de áudio).

Share this post


Link to post
Share on other sites
É só digitar os parâmetros na tela do Chameleon, o que você digita aparece no canto inferior esquerdo da tela.

 

 

O kernel panic dessa tela é por causa da VoodooHDA (driver de áudio).

 

OLA ESTOU DE VOLTA !!

 

VOLTANDO AO MEU CASO, INSTALEI O SYSTEMA DO MAC NO DISCO E QUANDO DOU BOOT COM CPUS=1 BUSRATIO=17 -V NO hp 2143 ELE PARA NESSA TELA DEPOIS DE VARIAS TELAS PASSADAS CARREGANDO DRIVERS ! ESPERO QUE DIGA ALGO ESSA TELA !!post-555610-1274283734_thumb.png OBRIGADO SE PUDER AJUDAR !!

Share this post


Link to post
Share on other sites
Está usando kernel legacy?

 

Poxa aleluia funcionou!!! realmente era so selecionar o kernel Legacy e o bootloader e a atualizacao 10.6.2 e mais nada, estava selecionando drivers do suporte a notbook atoa.

agora preciso arrumar o kext da nvidia gt 320m video e broadcom 4322 wireless !! som funcionando !!!

se souber sobre essas kexts da um toque ! to pesquisando tb, vi que a broadcom 4322 tem que modificar a .plist do kext IO80211Family mas nao sei fazer isso ! kext da placa de video nvidia gforce gt 320m ainda nao encontrei nada.

MAS OBRIGADO POR TODAS AS RESPOSTAS, ME AJUDOU MUITO !!!!! VALEUUUUUUUU

Share this post


Link to post
Share on other sites

Sobre a edição do plist, veja esse tópico, é o mesmo procedimento, só muda a kext

http://www.insanelymac.com/forum/index.php?showtopic=218797

 

Edite o arquivo

/System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AppleAirPortBrcm4311.kext/Contents/Info.plist

e adicione em IONameMatch

								<string>pci14e4,4322</string>

 

Sobre a nVidia, não sei se sua placa é suportada, mas veja esse tópico, acho que vai funcionar

http://www.insanelymac.com/forum/index.php?showtopic=215980

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×