Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
eNeos

fstab et partition Windows 7

11 posts in this topic

Recommended Posts

'lut vous,

 

Je n'arrive pas à empêcher SL de monter la partition "Réservé au système" au démarrage.

 

Cette jolie partition totalement inutile et gentiment créée par Windows 7 se trouve en disk0s1 et aucune UUID n'est annoncée.

J'ai essayé de passer par le LABEL, par /dev/disk0s1, mais rien y fait.

 

Aucun soucis pour les autres partitions qui ne m'intéressent pas, que ce soit par UUID ou par LABEL.

 

 

Y'a-t-il une solution ou ma première tache de la journée sera dorénavant de démonter une partition Windows ? ;)

Share this post


Link to post
Share on other sites

Ah cette {censored} partion "réservée au système", d'ailleurs tu n'as pas un bug d'affichage lors du dual boot de chameleon (ou pcefi)?

Je crois qu'avec le logiciel de avosmac "Avosmac2DiskVisibility" tu peux masquer la partition que tu veux.

 

NB: mon astuce pour installer seven sans avoir cette maudite partion, formater avec SL en fat32 et faire formater en ntfs lors l'installation de seven (si tu supprimes la partition via seven c'est mort il te fera son "réservé au sytème")

Share this post


Link to post
Share on other sites

'lut m'sieur

Pour l'instant, j'ai un AppleScript qui démonte la partition au démarrage. Sinon, juste pour la masquer, un simple drag&drop depuis la zone "Appareils" du finder vers le bureau suffit. Mais alors empêcher le montage :) J'crois bien que j'ai tout essayé.

 

J'essaierai ton astuce à mon prochain "j'explose tout" :)

 

J'ai bien le bug dans chameleon et il apparaît également en mode -v. Par contre, si je vais voir le journal il est correctement écrit. Encore un coups à la ANSI/UTF8/KEKECHOSE. J'ai essayé de passer en octal et même en séquence ESC sans succès.

Share this post


Link to post
Share on other sites

Je n'ai pas essayé le diskvisibility puisque d'après ce que j'ai compris, il ne fait rien de plus que je ne fais déjà.

Share this post


Link to post
Share on other sites

C'est peut être un peu barbare, mais pour éviter cette partition sur Seven voici ma méthode.

 

Je débranche tout les disques sata et je branche un seul disque, celui pour Seven sur le port Sata "1" (premier).

Au préalable j'ai sous OSX formaté mon disque en format PC.

Puis sous l'installateur de Seven, il me semble choisir l'option supprimé et formater, et il me crée un seul disque. Et non deux avec la partition de {censored} à la con.

 

Je pense que le MBR créé sous OSX y est pour quelque chose...

 

post-269213-1266412675.png

 

Ce sont tous des disques physiquement indépendant et tous en SATA

Share this post


Link to post
Share on other sites

Oki merci !

Même principe qu'Alex sur le principe si je comprends bien. Tu remplis ton disque comme ça Win7 n'a plus la place de coller son... bazar.

 

Je ne vais pas tarder à y venir, je sens que ma EX58-UD5 va finir à la poubelle d'ici très peu de temps. Jamais vu une :D pareil :hammer:

Share this post


Link to post
Share on other sites
Oki merci !

Même principe qu'Alex sur le principe si je comprends bien. Tu remplis ton disque comme ça Win7 n'a plus la place de coller son... bazar.

 

Je ne vais pas tarder à y venir, je sens que ma EX58-UD5 va finir à la poubelle d'ici très peu de temps. Jamais vu une :) pareil :hammer:

 

Oui en gros c'est ça :D

Share this post


Link to post
Share on other sites

Désolé de relancer ce thread mais j'ai été confronté à ce problème aujourd'hui.

 

Une solution toute bête est de démarrer sous Windows et lancer "Gestion de l'ordinateur". Vous lancez ensuite le gestionnaire de disques et il suffit de renommer la partition "Réservé au système" en "System Reserved" (ou whatever..). Il ne reste plus qu'à ajouter ceci dans le /etc/fstab

 

LABEL=System\040Reserved					    none    ntfs    ro,noauto	   0	   0

Share this post


Link to post
Share on other sites

C'était pas tant les espaces qui posaient problème. C'était les "éè" dans l'orthographe française de "System Reserved", car ça ne supporte pas les codes ascii octal étendus.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×