Jump to content
InsanelyMac Forum
oldnapalm

Instalação do Chameleon 2.0

Recommended Posts

Instalador:

 

Chameleon 2.0 RC4: http://www.mediafire.com/?in0nzna4xej

 

Chameleon 2.0 RC5: http://www.insanelymac.com/forum/index.php?showtopic=227833

 

Apenas selecione o volume de destino. Pode ser usado em dual boot, não danifica o boot do Windows 7.

 

 

Instalação manual:

 

Baixe o pacote de binários do Chameleon 2.0 e extraia o conteúdo.

 

No terminal, rode os comandos:

   cd ~/Downloads/Chameleon-2.0*/i386/
  diskutil list

veja o IDENTIFIER da partição onde vai instalar (diskDsP)

nos próximos comandos substitua D pelo número do disco e P pelo número da partição

   sudo -s
  ./fdisk -f boot0 -u -y /dev/rdiskD
  dd if=boot1h of=/dev/rdiskDsP
  cp boot /Volumes/[nome da partição]
  fdisk -e /dev/diskD
  f P
  write
  y
  exit

para instalar os Extras (opcional)

   mkdir /Volumes/[nome da partição]/Extra
  mkdir /Volumes/[nome da partição]/Extra/Extensions
  cp /Volumes/[nome da partição]/Library/Preferences/SystemConfiguration/com.apple.Boot.plist /Volumes/[nome da partição]/Extra
  cp -R ../Optional\ Extras/Themes /Volumes/[nome da partição]/Extra

 

O Chameleon 2.0 tem a opção GraphicsEnabler que dispensa o uso de kext ou string EFI para habilitar o funcionamento dos drivers de vídeo. Para utilizá-la basta editar o arquivo /Extra/com.apple.Boot.plist e adicionar as linhas:

		<key>GraphicsEnabler</key>
	<string>y</string>

Se você utilizava alguma kext (Titan, Natit, NVdarwin, NVenabler, ...) ou string EFI, lembre-se de removê-la.

 

O aplicativo Lizard (por sonotone) facilita a configuração do Chameleon 2.0

 

lizard.png

 

Instalação pelo Lizard:

 

Selecione a aba Install and Update.

 

Se você ainda não tem o pacote de binários, clique em Download files, selecione a versão mais recente e faça o download.

 

downloady.png

 

No site, clique onde diz "Alternatively you can click here to download the requested file."

 

Selecione a partição onde vai instalar, clique em Select folder e selecione a pasta extraída do pacote de binários.

 

install.png

 

Deixe os 3 arquivos do bootloader selecionados (boot0, boot1h e boot), clique em Install Chameleon e confirme.

 

A instalação dos Extras é opcional.

Share this post


Link to post
Share on other sites
Advertisement

Parece que você ainda tem o device-properties no com.apple.Boot.plist

 

Anexa o arquivo para eu dar uma olhada.

 

Você tentou usar o Lizard para detectar o PciRoot?

Share this post


Link to post
Share on other sites
Parece que você ainda tem o device-properties no com.apple.Boot.plist

 

Anexa o arquivo para eu dar uma olhada.

 

Você tentou usar o Lizard para detectar o PciRoot?

Ja resolvi tudo mas claro gracas a suas dicas. parabens e muito obrigado gostaria de saber 30% do que tu sabe. um dia chego la. rs

ja fiz essa pergunta num topico.. quando eu deixar meu sistema perfeito redondinho e tals, tem como gravar uma imagem do sistema em dvd por exemplo?

Share this post


Link to post
Share on other sites

Tem programas que fazem isso ... uma imagem do HD inteiro sim. Não lembro o nome mas aguarde que alguem vai responder.

 

PS: Evite a duplicidade de postagens.

 

...

Voltei. Lembrei do nome ... CarbonCopyCloner

Share this post


Link to post
Share on other sites

Quando eu executo o 'dd if=boot1th ... " , o terminal retorna com 'boo1th: No such file or directory."

 

O que fazer?

Share this post


Link to post
Share on other sites
Quando eu executo o 'dd if=boot1th ... " , o terminal retorna com 'boo1th: No such file or directory."

 

O que fazer?

É boot1h, não boot1th.

Share this post


Link to post
Share on other sites
É boot1h, não boot1th.

 

 

HUhuashusahu, mas que burro que eu sou hein ¬¬ . Tava vendo um 't' ali uahsuhsauh . Realmente, preciso de um oculos novo :x

 

Vlw por toda ajuda ai old ;p

 

 

Ahh, o procedimento da 'GraphicsEnable' é obrigatório?

Share this post


Link to post
Share on other sites
Ahh, o procedimento da 'GraphicsEnable' é obrigatório?

Obrigatório não é, mas útil para as placas suportadas, não sei se é o caso da sua.

Share this post


Link to post
Share on other sites

Blz, atualizei, o Chameleon apareceu bonitinho.

 

Só que quando eu escolho o Leopard, vai pra tela da maçã (¬¬) e reinicia do nada. E só boota mesmo quando eu insiro o DVD do iDeneb e no F8 uso o 'rd=disk0s1' .. Ja até botei na key 'Kernel flags' a string pro 'disk0s1', mas nem assim ele boota direto..

Share this post


Link to post
Share on other sites

Lembre que o arquivo de configuração do Chameleon v2 é /Extra/com.apple.Boot.plist, diferente do v1 que fica em /Library/Preferences/SystemConfiguration.

 

Você tentou fazer o boot no modo verbose? Tente digitar "cpus=1 -v" na tela do Chameleon, após selecionar o Mac, mas antes de apertar enter (o que você escreve aparece no canto inferior esquerdo).

Share this post


Link to post
Share on other sites

Aham, o Boot.plist das versões tão em diretórios diferentes, mas a que eu to usando é o Chameleon 2.0 RC4, mas eu adicionei o 'rd=disk0s1' no Kernel Flag dos 2 Boot.plist, só pra ter certeza.. Mas mesmo assim nada, ainda continua reiniciando, e eu tenho que bootar com o DVD e com o 'rd' .

 

Quando eu faço o boot com 'cpus=1 -v' , o computador reinicia muito rápido, nem consigo tirar uma foto direito do que aparece escrito..

Share this post


Link to post
Share on other sites

Talvez seja um bug do Chameleon v2 no seu equipamento.

 

No meu P4 até o RC3 reiniciava antes de carregar o Chameleon, e o v1 funcionava normalmente. No RC4 foi resolvido.

 

Tente instalar o Chameleon v1, basta substituir o arquivo boot na partição do Leopard.

 

http://www.mediafire.com/?nwnjethyezz

 

Se não resolver tente refazer toda a instalação do v2.

Share this post


Link to post
Share on other sites

Tentei aqui, mas tbm n deu certo.. O Chameleon foi pra vesão 1, mas dai no 'cpus=1 -v', mas o notebook reinicia muito rápido e nao dá nem pra tirar foto..

 

Eu ainda nao instalei nenhuma kext, será que tá precisando da kext do Chipset?

Share this post


Link to post
Share on other sites

Não deveria reiniciar por falta de kext.

 

Tentou refazer toda a instalação da v2?

 

Se tiver como gravar vídeo, grave o boot, depois veja quadro a quadro para ver o que aparece escrito.

Share this post


Link to post
Share on other sites

Não baixei ainda o programa, só quero tirar 2 dúvidas antes:

O pendrive de boot eu faço pelo lizard também? ali onde tem bootable ISO?

 

outra coisa, vou explicar como consegui arrumar o video Nvidia PNY 9800gt, segui

esse tuto http://aquamac.proboards.com/index.cgi?boa...&thread=509

e mesmo assim fiquei como uma resolução baixa acredito que não funcionou, eu tinha a versão 10.5.5 aí fiz o update da apple para a versão 10.5.8 e quando iniciou o OSx já estava consertado o meu video com todas as resoluções,

utilizo a 1920x1080 no monitor e 1250x720 em uma tv como extensor do monitor para assistir filmes.

pelo que eu vi alí tem graphics injection desculpe a minha ignorancia mais preciso saber

se marcando essa opção não vai estragar o que eu já tenho..

 

Obrigado..

Share this post


Link to post
Share on other sites
O pendrive de boot eu faço pelo lizard também? ali onde tem bootable ISO?

Faz pelo Lizard, mas em Install and Update, como explicado no post.

 

pelo que eu vi alí tem graphics injection desculpe a minha ignorancia mais preciso saber

se marcando essa opção não vai estragar o que eu já tenho..

Marcando essa opção não precisa da GFX string, ele faz automaticamente. Se prefere a string, não marque Graphics Injection.

 

Veja mais detalhes nesse tópico

http://www.insanelymac.com/forum/index.php?showtopic=215980

Share this post


Link to post
Share on other sites

Boas

 

Como posso predefinir o Windows para arranque?

 

É que eu uso mais o Windows do que o Mac OS, e sempre que ligo o computador tenho de cancelar o arranque do Mac OS e escolher o Windows, o que se torna um pouco maçador

 

Obrigado

Share this post


Link to post
Share on other sites

Eu estou com um problema aqui, tentei de todo jeito instalar duas versões diferentes no meu notebook Sim+ 1062.

 

Todos eles instalavam normalmente mas na hora de dar o boot travava na tela da maça com um aviso para eu forçar o desligamento da maquina.

 

baixei a versão iDeneb 1.5 e quando fui dar boot no DVD acabei entrando no sistema que eu havia instalado.

 

Com o DVD iDeneb no drive eu consigo dar boot no Mac, mas sem eu não consigo.

 

O meu boot ta meio bagunçado, estou tentando arrumar, pois antes eu tinha Windows 7 e Ubuntu instalado com o Grub gerenciando os boots, mas depois que eu instalei o Mac OS eu perdi o grub e com isso mandei reparar o boot com o DVD do windows 7, depois entrei no windows e instalei o EasyBCD e cadastrei uma entrada pro linux e outra pro Mac OS, que é por onde eu não consigo dar boot.

 

Creio eu, que a versão do Chameleon que ta instalado é a 1.0 e a do iDeneb conforme eu li é a 2.0

 

Alguem consegue me ajudar?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×