Jump to content

A bunch of problems I need help fixing!


3 posts in this topic

Recommended Posts

Most of this stuff probably boils down to some DSDT editing, which is very hard for me to do since my board is very rare (and most other ones are so different that no edits seem to work), I haven't found any guides for it, not to mention pre-edited dsdts. In an ideal world, someone will edit my DSDT for me, but I would still be extremely grateful for some tips, on some edit I should do or something :(

Cutting it down: I need help understanding the DSDT related to sleep (C-States?) and speedsteping/throttling (P-States?).

The Main (functionality related) problems I have up to now are:

  1. My IDE DVD and CD drives aren't detected or usable in OS X. They are fine in other OSs and Chameleon. In System Profiler, I can see two "ATA Bus" devices, but no info on them and no CDs or DVDs will be read. Solution: I have read that IDE CD/DVD drives+JMicron+OS X=no CD or DVD drive; so I guess it's time to go SATA!
  2. Native power management not working fully: without NullCPUPowerManagement.kext my temps go up ~20ºC. I don't care about speedsteping (now I got speedsteping, but if I identify as a MacPro4,1 my temps still go up, but I can live with 3,1 for now), but the C-States should be related to all this (my guess) and those in turn are related to sleep (which is broken for me). I get no CPU temps read (in iStat) (now only CPU "A" AND "B"), and if I boot in verbose I see a message similar to: turbo boost enabled but no p-states found (not anymore!). I have looked around in the SSDT tables and the DSDT table, but just can't make sense of it. All I don't have now is sleep, see this thread
  3. Sleep dosn't work (the computer kind of looks like it goes into it, it powers everything off, and the debug LED goes to "03", which the MB manual says is:
    "Disable NMI, Parity, video for EGA, and DMA controllers. Initialize BIOS, POST, Runtime data area. Also initialize BIOS modules on POST entry and GPNV area. Initialize CMOS as mentioned in Kernel Variable "wCMOSFlags".
    If I touch the mouse or keyboard, it seems to wake up, but then immediately reboots. Once it get's past Chameleon, it looks like it starts to load the hibernate image (just like a real mac) and then reboots -again. I have to boot from my install disk and delete the image from the Terminal. Then, it'll boot like a champ. Is this the famous USB/UHCI sleep issue?. In the BIOS I have "Suspend to RAM" set on auto (it's that or disabled on my BIOS), video repost off and C states up to C3 or C6 (I don't know which one to use, but it doesn't make a difference anyways.
    I'm pretty sure that this is because OS X doesn't read any C-States, and I imagine no P-States either, from SSDT. Question: Windows (or is it only OS X that doesn't?) gets it thou a table called SSDT from the BIOS and OS X expects it to be in the DSDT, under the processor section. Is there a generic i7 920 processor section or is there any info dependent on the motherboard? I found some here (on insanleymac) but it gave me a KP. I tried the EvoSx86 method, but it didn't lower my cpu temps. This is the same with or without NullCPUPowerManagement.kext


And the ones of lesser importance:

  1. My PCI network devices aren't detected correcly: pci168c,24:
    Type: Ethernet Controller
    Bus: PCI
    Vendor ID: 0x10ec
    Device ID: 0x8139
    Subsystem Vendor ID: 0x10ec
    Subsystem ID: 0x8139
    Revision ID: 0x0010
    Type: Ethernet Controller
    Bus: PCI
    Vendor ID: 0x10ec
    Device ID: 0x8168
    Subsystem Vendor ID: 0x1849
    Subsystem ID: 0x8168
    Revision ID: 0x0003
    Link Width: x1
    Type: Other Network Controller
    Bus: PCI
    Vendor ID: 0x168c
    Device ID: 0x0024
    Subsystem Vendor ID: 0x1186
    Subsystem ID: 0x3a70
    Revision ID: 0x0001
    Link Width: x1
    I have no idea about the ethernet ones, but I know the AirPort one to be in the IO802.11.kext (or something like that) .plist. So from what I think, it acquires that info (pci168c,24) from the device, so changing the name in the .plist would just render my card useless.
  2. I can't get any AppleHDA method to work, but that may be because I have an ALC890. I made a codec dump from Ubuntu -which detected it as an ALC890- and it said it was an ALC889a, and knowing that they are almost the same I would think that any ALC889a method would work. I'm currently using VoodooHDA, but I miss automatic headphone switching and stuff. In VoodooHDA, my card gets detected as a ALC885, and I would like it at least to be detected as an ALC889a (I'm guessing that would fix auto jack switching & stuff), how do I do this?. I have no HDEF or AZAL devices in my DSDT, but Ubuntu could detect my card (as a ALC889a) and sound worked fine.


Now for the specs and configs (even the useless):

  • ASRock x58 Extreme (ALC890, RTL8111D, ICH10R)
  • PNY GeForce 9800 GT
  • CoolMax CoolMax RM 1000b
  • Artic Cooling Frezer 7 Pro Rev 2
  • XCLIO A380 Case
  • Audio out thru green rear port
  • USB mouse and keyboard (until I get bluetooth)
  • 1 1920x1080 monitor and 1 1280x1024 monitor.
  • 2x1TB SATA II HDDs
  • DLink DWA-556 Extreme
  • Cirago BTA-3210
  • PCI Realtek RTL8139 Ethernet Card
  • DVD-RW IDE drive, CD IDE drive
  • Floppy drive. I have it just for the sake of it not laying around, pulled it out a a Pentium I. I don't need it to work in OS X
  • 4GB USB pen-drive for Chaemaleon.

It would be cool to delete as many of my kexts as possible, so if you see any I can replace with some DSDT code, please tell! I have seen fixes to remove various ones (IOAHCIBlockStorageInjector.kext, NullCPUPowerManagement.kext & OSXRestart.kext), but as I said in the beginning, I couldn't get any to work, be it because of my bord or my lack of knowledge.

Attached is a .zip of my Chameleon files:

Switched to AsereBLN's booter v 1.1.7


If you need anything else please just ask! I greatly apretiate any help I can get, being such a noob is hard ;)

Link to comment
Share on other sites


  • Create New...