Jump to content

EFI myhack broke my authentic iMac 3.06


4 posts in this topic

Recommended Posts

DUMBEST thing I have ever done. I have built my own OSX86 box. I am smarter than this.


Accidently used MyHack to ruin my firmware/EFI on my 'authentic' real iMac (Early 2008), model 8,1.. (10.5.8)


There is ZERO information on 'firmware restoration' on Apple.com support.


I CAN boot to the original Leopard system restore OSX installer. Have tried restoring from Time Machine.


Won't boot. Only white screen instead of the Apple logo.



HOW TO RESET? Anyone hosed a real Mac with MyHack installer accidently? I CANNOT be the first....



Thanks for ANY info! The local shop reccomends trying to install again via Target disk mode.... I need firmware restored, the problem is NOT on the hard drive... How to 'flash' the EFI firmware, now wrecked by Chameleon...?????


Rhett (rhettt@gmail.com)

Link to comment
Share on other sites

Hey thanks!


That is what I will try! Hope it's all so simple as MyHack tried to install MBR and all I need to do is turn it back to GUID...



Both those support.apple.com/kb/HT2434 are identical... Did you have a second link for me to look at?






Link to comment
Share on other sites


  • Create New...