Jump to content

Chameleon Bootloader doesn't load from hard drive after install


pcmantinker
 Share

1 post in this topic

Recommended Posts

I've got an older HP laptop with an AMD Turion 64 processor and an ATA hard drive. I made a custom boot132 CD to use the mach_kernel.test7 AMD kernel and include an ATA kext for my hard drive. I've successfully installed Snow Leopard 10.6 with the custom boot132 disc, but I can't boot Chameleon from the hard drive. I can boot Chameleon from the CD however. I've tried manually installing Chameleon as well as using the automated installers to install Chameleon to my OSX partition. I've tried everything from Chameleon 2 RC1 to RC4. I've also tried using the PC EFI method. Also, I've tried installing the bootloader to my EFI partition, but it refuses to boot.

 

 

Here is the output from lspci:

00:00.0 Host bridge: ATI Technologies Inc RS480 Host Bridge (rev 01)

00:01.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge

00:04.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge

00:13.0 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller

00:13.1 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller

00:13.2 USB Controller: ATI Technologies Inc IXP SB400 USB2 Host Controller

00:14.0 SMBus: ATI Technologies Inc IXP SB400 SMBus Controller (rev 11)

00:14.1 IDE interface: ATI Technologies Inc IXP SB400 IDE Controller

00:14.3 ISA bridge: ATI Technologies Inc IXP SB400 PCI-ISA Bridge

00:14.4 PCI bridge: ATI Technologies Inc IXP SB400 PCI-PCI Bridge

00:14.5 Multimedia audio controller: ATI Technologies Inc IXP SB400 AC'97 Audio Controller (rev 02)

00:14.6 Modem: ATI Technologies Inc SB400 AC'97 Modem Controller (rev 02)

00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration

00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map

00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller

00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control

01:05.0 VGA compatible controller: ATI Technologies Inc Radeon XPRESS 200M 5955 (PCIE)

06:02.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)

06:04.0 CardBus bridge: Texas Instruments PCIxx21/x515 Cardbus Controller

06:04.2 FireWire (IEEE 1394): Texas Instruments OHCI Compliant IEEE 1394 Host Controller

06:04.3 Mass storage controller: Texas Instruments PCIxx21 Integrated FlashMedia Controller

06:04.4 SD Host controller: Texas Instruments PCI6411/6421/6611/6621/7411/7421/7611/7621 Secure Digital Controller

06:06.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

 

 

Please let me know if there's anything that I can do. Thanks.

 

 

EDIT:

After doing one last clean install of Snow Leopard on the old AMD laptop, I found that Chameleon will boot if I continuously press a key on the keyboard while the boot process starts. After that, I can boot into Snow Leopard just fine. I've set the default kernel to mach_kernel.test7 so that it boots automatically. Even though it boots, I'd like to know if there's a way to get Chameleon to start without me having to press a key on the keyboard repeatedly. If you'd like more of description of what happens, I'll see about making a video later.

Link to comment
Share on other sites

 Share

×
×
  • Create New...