Jump to content

Cannot not backup - Not familiar with kexts


3 posts in this topic

Recommended Posts

I am getting " _CFGetHostUUIDString: unable to determine UUID for host. Error: 35" whenever I try any type of backup scheme or program. I am not familiar with kexts at all. I followed instructions from lifehacker to install SL. I would really like to backup my system.


I have an internal WD Cavier Green 1TB drive and I am trying to backup to an external 1TB seagate.


I have osx86tools and have tried changing kexts but it did nothing.





Link to comment
Share on other sites

I just tried this solution:



sneosx86 has solution that worked for me


..."This workaround will help you to remove the "_CFGetHostUUIDString: unable to determine UUID for host. Error: 35" error.

1.) BACKUP your /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist
2.) Open /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist
3.) ADD AFTER <string>Ethernet</string></dict> the following:
<key>BSD Name</key>
4.) IF you have more than 3 interfaces or there is an "en3" interface change it to "en4" or a higher number, don't forget to change this "<integer>3</integer>" to "<integer>4</integer>".
5.) You need to REBOOT
6.) If this work for you please tell me.
7.) If this workaround did not work please provide your system.log and your NetworkInterfaces.plist.

Why does this error happen?
Well at looking at the source code of the configd there is a plugin "InterfaceNamer" it seams the plugin will always skip interfaces
that are IOBuiltin = false. The "<key>IOBuiltin</key>" cannot be changed because the plugin will check and restore it on next boot.
But it does not check if wireless interfaces <key>SCNetworkInterfaceType</key><string>IEEE80211</string> are IOBuiltin."...

Posts: 1
Joined: Fri Sep 29, 2006 9:06 am



No luck

Link to comment
Share on other sites

Well not only did it not work. But I seem to have screwed up my networking. I backed the NetworkInterfaces.plist like it said, but somehow no when I have to restart, I have to use the -f boot and then I get the network. Funny thing that now my vmware installed win7 internet connection that WAS working now, is not. Probably tied to this debacle.


I will search more and try nd figure it out. If anyone has any pointers, that would be great!





Link to comment
Share on other sites


  • Create New...