Jump to content
InsanelyMac Forum
Sign in to follow this  
mk1277

SL 10.6.2 on HP dc5750 - and iMovie '09 problem

Recommended Posts

All-

 

I just wanted to share my experiences and setup so that it may help others. I've also run into an iMovie problem. My machine has been previously able to run iDeneb 1.4 (OSX 10.5.6).

 

I did the install to the new SL disk using the AMD install method commonly described here and on the internet (install from existing Mac OS). My system is currently using the modbin.test7 kernel and Chameleon 2.0 RC4. I installed from a retail SL DVD. I have added a DSDT file, but have made no patches to it. The patcher tool needs to be forced to compile on this machine.

 

My setup:

HP dc5750 microtower

http://h10010.www1.hp.com/wwpc/us/en/sm/WF...96-3252512.html

 

CPU

AMD Athlon x64 dual core

 

RAM

4GB

 

Chipset (for SATA support)

ATI xPress -> use AppleATIATA.kext in /Extra/Extensions

 

Video

NVidia GeForce 8400 GS card -> just turn on GraphicsEnabler in Chameleon (boot.plist)

 

Sound

ALC260 codec -> use Azalia SL package from kexts.com

 

NIC

Broadcom 5751 -> using patched AppleBCM5751.kext from 10.5.6 in /Extra/Extensions along with IONetworkingFamily.kext

 

  • I don't use power management, so I don't care if the system can come back from sleep mode.
  • QE/QI just works
  • System updates work (currently on 10.6.2)
  • Sound output works (Green line out) but volume can't be controlled from top panel. Must use System Preferences. I tried VoodooHDA.kext but kept getting distorted/crackling audio. The Azalia package works fine.

 

There's still some weird bug with Chameleon and this particular machine. If my Logitech USB keyboard/mouse combo is plugged in during boot, I get a Memory Allocation Error. I have no idea what the problem is, but unplugging the device until Chameleon loads or using a PS/2 keyboard has always done the trick.

 

Disc burning (SATA DVD-DL with LightScribe) doesn't work even though System Profiler properly detects my drive and it's capabilities. It's my understanding that this is common to AMD machines and OSX86. I never had it working under Leopard and don't expect to get it working on SL.

 

Finally, iMovie currently will not export movies. The program crashes whenever the export begins.

 

Edit (03-29-2010): I've added my patched Broadcom kext and the IONetworkingFamily kext that I use.

 

Edit: I have fixed two issues and struck them. I totally forgot any need for CPUID patching. I ran Marvin's AMD Utility v.25 and now both the volume adjustment in the top panel and iMovie exports are working. I'll report back if I notice any other fixed regarding power managment or disc burning.

AppleBCM5751Ethernet.kext.zip

IONetworkingFamily.kext.zip

Share this post


Link to post
Share on other sites
Advertisement

I just found out that the strange memory allocation error in Chameleon can be solved when booting Chameleon out of grub2!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×