Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


iTunes won't recognize my iPod touch, error message

3 posts in this topic

Recommended Posts

I had three older imacs, just bought the imac quad-core i7 (it's awesome) all is great except for one thing!! I have 2 ipod touch, 2 iphones, and a classic ipod. All worked perfectly with my old computer, and all but one ipod touch (my young sons) connect perfectly with the new system. When I plug his in it comes up in iPhoto, with the ipod name listed, it shows an ipod connected to the computer when I look at the "about this computer" settings, but it gives me an error message from iTunes and will not recognize it. Error says:

iTunes could not connect to this ipod because an unknown error has occured (0xE800000A)


I have tried:

1. Restarting my computer many times


2. Resetting and clearing the touch completely


3. Uninstalling and reinstalling iTunes ( with instructions from apple web site) twice


Nothing seems to make a difference.


When I plug it back into my old computer it comes right up, no problem and works on my other iMacs.

I believe it must be something with iTunes because iPhoto recognizes it, right?


My son needs his Touch back, he loves it, and his brothers works just fine.


Any ideas out there? I am not a professional or novice Mac person, in the middle with my skills. So I hope to be able to follow your instructions. I have not tried calling Apple yet.


THANK YOU for reading this.

Share this post

Link to post
Share on other sites

Well, from what I found, the problem may be with the iTunes version itself. If you are on the latest versions, try downgrading to 8.1 or 8.2 (I found that 9.x is pretty annoying). If you are on 8.x try upgrading (you never know).

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.